11 Replies Latest reply on Jul 23, 2009 10:53 AM by 439075

    oratab populated, but 11G database doesn't start

    user596857
      I've installed Oracle 11g on Redhat 5.
      And created a database with dbca.
      And set the oratab for it to start on boot.

      But the database does not start on boot.

      I noticed that there is more than one oratab file:



      find / -type f -iname "oratab"

      /etc/oratab
      /oracle/oracle11/product/11.1.0/db_1/install/oratab


      cat /etc/oratab

      test:/oracle/oracle11/product/11.1.0/db_1:Y

      The other file was empty:

      ls -l /oracle/oracle11/product/11.1.0/db_1/install/oratab
      -rwxr-xr-x 1 oracle11 dba 0 Jul 20 19:45 /oracle/oracle11/product/11.1.0/db_1/install/oratab

      But I added the lines from the one file to the other.
      And it still didn't come up when I rebooted.


      Is 11G different from the previous versions?

      What is the secret to getting the database to come up
      automatically after rebooting the machine?

      Thanks
        • 2. Re: oratab populated, but 11G database doesn't start
          user596857
          Thanks. That was a start.
          Now I'm getting issues with rsh.

          The db didn't come up upon boot.
          I ran the script manually, as root, and got:

          /etc/init.d/dbora
          + ORACLE_HOME=/oracle/oracle11/product/11.1.0/db_1
          + ORACLE=oracle11
          + PATH=/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin:/oracle/oracle11/product/11.1.0/db_1/bin
          ++ hostname
          + HOST=bronze.gateway.2wire.net
          ++ uname
          + PLATFORM=Linux
          + export ORACLE_HOME PATH
          + '[' '!' '' = ORA_DB ']'
          + '[' Linux = HP-UX ']'
          + rsh bronze.gateway.2wire.net -l oracle11 /etc/init.d/dbora ORA_DB
          connect to address 192.168.1.101 port 544: Connection refused
          Trying krb4 rsh...
          connect to address 192.168.1.101 port 544: Connection refused
          trying normal rsh (/usr/bin/rsh)
          bronze.gateway.2wire.net: Connection refused
          + exit
          [root@bronze ~]# which rsh
          /usr/kerberos/bin/rsh

          Any ideas?

          Thanks.
          • 3. Re: oratab populated, but 11G database doesn't start
            439075
            Hi,

            By default, Red Hat Linux puts /usr/kerberos/bin at the head of the $PATH variable. This will cause the Kerberos version of rsh to be executed.

            A workaround I typically use is to rename the kerberos version of rsh so that the normal rsh command will be used.

            Do the following:

            # su -

            # which rsh
            /usr/kerberos/bin/rsh

            # mv /usr/kerberos/bin/rsh /usr/kerberos/bin/rsh.original
            # mv /usr/kerberos/bin/rcp /usr/kerberos/bin/rcp.original
            # mv /usr/kerberos/bin/rlogin /usr/kerberos/bin/rlogin.original

            # which rsh
            /usr/bin/rsh

            Check if this workaround works for you also.

            Cheers,

            Marcello M.
            • 4. Re: oratab populated, but 11G database doesn't start
              user596857
              Thanks. I changed the file names, and rebooted.
              But again the db did not come up.

              which rsh
              /usr/bin/rsh

              Again I tried just running the script itself.

              /etc/init.d/dbora
              + ORACLE_HOME=/oracle/oracle11/product/11.1.0/db_1
              + ORACLE=oracle11
              + PATH=/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin:/oracle/oracle11/product/11.1.0/db_1/bin
              ++ hostname
              + HOST=bronze.gateway.2wire.net
              ++ uname
              + PLATFORM=Linux
              + export ORACLE_HOME PATH
              + '[' '!' '' = ORA_DB ']'
              + '[' Linux = HP-UX ']'
              + rsh bronze.gateway.2wire.net -l oracle11 /etc/init.d/dbora ORA_DB
              Permission denied.
              + exit


              So, I tried to see if I could ssh into the server:

              ssh bronze.gateway.2wire.net
              The authenticity of host 'bronze.gateway.2wire.net (192.168.1.101)' can't be established.
              RSA key fingerprint is cf:df:71:d4:ac:e2:a4:f1:42:cc:d6:ed:68:56:dd:81.
              Are you sure you want to continue connecting (yes/no)? y
              Please type 'yes' or 'no': yes
              Warning: Permanently added 'bronze.gateway.2wire.net,192.168.1.101' (RSA) to the list of known hosts.
              root@bronze.gateway.2wire.net's password:
              Last login: Mon Jul 20 20:54:50 2009

              - that worked.


              And then tried to see if I could rsh into the server:

              rsh bronze.gateway.2wire.net
              Password:
              Password:
              Login incorrect


              I think this part needs to work, not?
              How can I get this part to work?

              Thanks
              • 5. Re: oratab populated, but 11G database doesn't start
                439075
                Hi,

                Did you check link provided by ebrian?

                Marcello M.
                • 6. Re: oratab populated, but 11G database doesn't start
                  user596857
                  Yes, as I detailed in the thread a few posts ago.
                  • 7. Re: oratab populated, but 11G database doesn't start
                    439075
                    hi,

                    Yes, as I detailed in the thread a few posts ago.
                    ok! Sorry for asking...
                    + rsh bronze.gateway.2wire.net -l oracle11 /etc/init.d/dbora ORA_DB
                    Permission denied.
                    Check below link to see if it is helpful.

                    http://rmn.iqfr.csic.es/guide/man/lynux/chap3-3.htm

                    Marcello M.

                    In addition, the rsh daemon validates users using the /etc/hosts.equiv file or the .rhosts file found in the user's home directory.

                    In order to enable the "rsh" and "rlogin" services, you can follow below commands on both servers:
                    I did below test using two of my vmware.

                    # su -
                    # chkconfig rsh on
                    # chkconfig rlogin on
                    # service xinetd reload
                    Reloading configuration: [  OK  ]

                    In order to allow the "tempusr1" UNIX user account for example to be trusted among the servers, I created the /etc/hosts.equiv file on both servers:

                    # su -
                    # touch /etc/hosts.equiv
                    # chmod 600 /etc/hosts.equiv
                    # chown root.root /etc/hosts.equiv

                    Now I added all servers to the /etc/hosts.equiv file similar to the following example for both servers:

                    # cat /etc/hosts.equiv
                    +vmlinux_node01 tempusr1
                    +vmlinux_node02 tempusr1

                    Testing...
                    # su - tempusr1

                    $rsh vmlinux_node01 ls -l /etc/hosts.equiv
                    -rw------- 1 root root 78 Jul 22 15:06 /etc/hosts.equiv

                    $rsh vmlinux_node02 ls -l /etc/hosts.equiv
                    -rw------- 1 root root 78 Jul 22 15:06 /etc/hosts.equiv

                    Marcello M.

                    Edited by: Marcello M. on Jul 22, 2009 3:12 PM
                    • 8. Re: oratab populated, but 11G database doesn't start
                      user596857
                      Thanks.

                      I did the following. Some luck.
                      But still, the DB startup script is not working.


                      cat /etc/hosts.allow
                      #
                      # hosts.allow This file describes the names of the hosts which are
                      # allowed to use the local INET services, as decided
                      # by the '/usr/sbin/tcpd' server.
                      #
                      bronze

                      bronze.gateway.2wire.net


                      I added a file for root also:

                      cat /root/.rhosts
                      #
                      # hosts.allow This file describes the names of the hosts which are
                      # allowed to use the local INET services, as decided
                      # by the '/usr/sbin/tcpd' server.
                      #
                      bronze

                      bronze.gateway.2wire.net



                      And for oracle11:

                      cat /home/oracle11/.rhosts
                      #
                      # hosts.allow This file describes the names of the hosts which are
                      # allowed to use the local INET services, as decided
                      # by the '/usr/sbin/tcpd' server.
                      #
                      bronze

                      bronze.gateway.2wire.net



                      which tcpd
                      /usr/sbin/tcpd


                      -------------

                      su - root
                      chkconfig rsh on
                      chkconfig rlogin on
                      service xinetd reload
                      Reloading configuration: [  OK  ]




                      touch /etc/hosts.equiv

                      ls -l /etc/hosts.equiv
                      -rw-r--r-- 1 root root 0 Jul 22 11:43 /etc/hosts.equiv

                      chmod 600 /etc/hosts.equiv
                      chown root.root /etc/hosts.equiv

                      edit /etc/hosts.equiv

                      cat /etc/hosts.equiv

                      +bronze                     root
                      +bronze.gateway.2wire.net   root

                      +bronze                     oracle11
                      +bronze.gateway.2wire.net   oracle11



                      reboot:

                      I can login as oracle11.
                      But it won't allow me to login as root.


                      If I'm logged in as oracle11:

                      [oracle11@bronze ~]$ rsh bronze
                      Last login: Wed Jul 22 12:23:57 on :0

                      [oracle11@bronze ~]$ rsh bronze.gateway.2wire.net
                      Last login: Wed Jul 22 12:28:32 from bronze

                      It doesn't even ask for the password.



                      If I'm logged in as root:

                      rsh bronze.gateway.2wire.net
                      Password:
                      Password:
                      Login incorrect

                      login: root
                      Password:
                      Login incorrect

                      login: oracle11
                      Password:
                      Last login: Wed Jul 22 12:28:59 from bronze


                      as oracle11:

                      rsh bronze ls -l /etc/hosts.equiv
                      -rw------- 1 root root 143 Jul 22 12:09 /etc/hosts.equiv



                      However, again the script is not working.


                      [root@bronze ~]# /etc/init.d/dbora
                      + ORACLE_HOME=/oracle/oracle11/product/11.1.0/db_1
                      + ORACLE=oracle11
                      + PATH=/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/root/bin:/oracle/oracle11/product/11.1.0/db_1/bin
                      ++ hostname
                      + HOST=bronze.gateway.2wire.net
                      ++ uname
                      + PLATFORM=Linux
                      + export ORACLE_HOME PATH
                      + '[' '!' '' = ORA_DB ']'
                      + '[' Linux = HP-UX ']'
                      + rsh bronze.gateway.2wire.net -l oracle11 /etc/init.d/dbora ORA_DB
                      bash: /etc/init.d/dbora: Permission denied
                      + exit


                      Is there something wrong with the script?
                      • 9. Re: oratab populated, but 11G database doesn't start
                        439075
                        Hi,
                        bash: /etc/init.d/dbora: Permission denied
                        According to the link provided earlier we have:

                        5 - Change the group of the dbora file to the OSDBA group (typically dba), and set the permissions to 750:

                        # chgrp dba dbora
                        # chmod 750 dbora

                        Do you have right permissions?

                        Marcello M.
                        • 10. Re: oratab populated, but 11G database doesn't start
                          user596857
                          Good one! That worked!

                          I'd made the file in the /home/ oracle11 home directory, and then copied it over.
                          The permissions were correct.
                          But the group ownership must have changed then.

                          Thanks a lot!
                          • 11. Re: oratab populated, but 11G database doesn't start
                            439075
                            Hi,

                            You're very welcome!! Glad to help!!

                            Marcello M.