1 Reply Latest reply: Jul 24, 2009 7:41 AM by Billy~Verreynne RSS

    mod_plsql: Long running URL

    587126
      Hi,
      we are getting the following error mod_plsql: Long running URL frequently when running reports, this error message comes in the log file after 5 minutes report started executing.

      Oracle version is Enterprise Edition Release 9.2.0.8.0 - 64bit Production.

      Please see the configuration details for mod_plsql


      # ============================================================================
      # mod_plsql DAD Configuration File
      # ============================================================================
      # 1. Please refer to dads.README for a description of this file
      # ============================================================================

      # Note: This file should typically be included in your plsql.conf file with
      # the "include" directive.

      # Hint: You can look at some sample DADs in the dads.README file

      # ============================================================================
      PerlModule TWAT::AccessHandler
      <Location /pls>
      PerlAccessHandler TWAT::AccessHandler
      SetHandler pls_handler
      Order deny,allow
      Allow from all
      AllowOverride None
      PlsqlDatabaseUsername xxxxxxx
      PlsqlDatabasePassword xxxx
      PlsqlDatabaseConnectString xxxxxxxxxxxxxxxxxxxxxxx
      PlsqlAuthenticationMode Basic
      PlsqlDefaultPage report_index.show
      PlsqlErrorStyle DebugStyle
      # PlsqlDocumentTablename scott.wwdoc_document
      # PlsqlDocumentPath docs
      # PlsqlDocumentProcedure scott.wwdoc_process.process_download
      </Location>


      # ============================================================================
      # mod_plsql Cache Configuration File
      # ============================================================================
      # 1. Please refer to cache.README for a description of this file
      # ============================================================================

      # Note: this file should be included into your plsql.conf with the "include"
      # directive.

      PlsqlCacheEnable On

      PlsqlCacheDirectory /opt/twat/oracle/product/10.1.2/Apache/modplsql/cache

      PlsqlCacheTotalSize 20971520

      PlsqlCacheMaxSize 1048576

      PlsqlCacheMaxAge 30

      PlsqlCacheCleanupTime Everyday 23:00

      # ============================================================================
      # mod_plsql configuration file
      # ============================================================================
      # 1. Please refer to plsql.README for a description of this file
      # 2. Parameters in this file have to be configured manually
      # ============================================================================

      # Configure Oracle HTTP Server to load mod_plsql
      LoadModule plsql_module /opt/twat/oracle/product/10.1.2/Apache/modplsql/bin/modplsql.so

      # Load in mod_plsql directives only if mod_plsql is loaded
      <IfModule mod_plsql.c>

      # ============================================================================
      # Global Settings Section : Directives that apply to all DADs
      # ============================================================================

      PlsqlLogEnable Off

      PlsqlLogDirectory /opt/twat/oracle/product/10.1.2/Apache/modplsql/logs

      # PlsqlIdleSessionCleanupInterval 15 (default)

      # PlsqlDMSEnable On (default)

      # ============================================================================
      # Database Access Descriptors Settings Section
      # ============================================================================
      include /opt/twat/oracle/product/10.1.2/Apache/modplsql/conf/dads.conf

      # ============================================================================
      # Cache Settings Section
      # ============================================================================
      include /opt/twat/oracle/product/10.1.2/Apache/modplsql/conf/cache.conf

      </IfModule>


      Please suggest what changes needs to be done in configuration files to avoid these errors.

      Regards
      Raghu
        • 1. Re: mod_plsql: Long running URL
          Billy~Verreynne
          user584123 wrote:
          Please suggest what changes needs to be done in configuration files to avoid these errors.
          You can only avoid this error by not running web processes (that typically should provide a response in seconds) that takes more than 5 minutes to produce a response.

          You can likely make the Apache timeout for a long running URL earlier or later - but that will not solve the problem when a web page response takes several minutes (or even hours) to generate.

          The real problem is the actual web process itself that takes so long to produce a response. Fiddling with the timeout on the web server merely addresses the symptom and not the cause.