This discussion is archived
1 2 3 4 5 6 Previous Next 75 Replies Latest reply: Nov 20, 2012 12:25 AM by Roman_OCP Go to original post RSS
  • 60. Re: Cannot open APEX http://127.0.0.1:8080/apex, but Oracle 10g express working
    Johnny98 Newbie
    Currently Being Moderated
    Hello Again!

    Hostname:
    C:\oraclexe\app\oracle\product\10.2.0\server\BIN>hostname
    Stevens

    Ping stevens:
    C:\oraclexe\app\oracle\product\10.2.0\server\BIN>ping stevens

    Pinging Stevens[192.168.1.101] with 32 bytes of data:

    Reply from 192.168.1.101: bytes=32 time<1ms TTL=128
    Reply from 192.168.1.101: bytes=32 time<1ms TTL=128
    Reply from 192.168.1.101: bytes=32 time<1ms TTL=128
    Reply from 192.168.1.101: bytes=32 time<1ms TTL=128

    Ping statistics for 192.168.1.101:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

    IPCONFIG:
    C:\oraclexe\app\oracle\product\10.2.0\server\BIN>ipconfig

    Windows IP Configuration


    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . : hsd1.co.comcast.net.
    IP Address. . . . . . . . . . . . : 192.168.1.101
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.1.1
  • 61. Re: Cannot open APEX http://127.0.0.1:8080/apex, but Oracle 10g express working
    438381 Guru
    Currently Being Moderated
    John

    The only conclusion I can draw from the tests and changes we have made thus far is that your computer's network configuration is somehow preventing the listener from starting up with 'Stevens' specified for the host in the listener.ora file.
    As as a last ditch effort , try installing the Microsoft loopback adapter as described here http://support.microsoft.com/kb/839013
    and see if it makes a difference.

    varad
  • 62. Re: Cannot open APEX http://127.0.0.1:8080/apex, but Oracle 10g express working
    Johnny98 Newbie
    Currently Being Moderated
    Hello Varad,
    Still no luck...unbelievable.

    Thanks,
    John
  • 63. Re: Cannot open APEX http://127.0.0.1:8080/apex, but Oracle 10g express working
    438381 Guru
    Currently Being Moderated
    John:

    Can you check the setting of the 'shared_servers' database parameter ?
    From sqlplus

    show parameter shared_server


    Should be a positive integer


    Varad
  • 64. Re: Cannot open APEX http://127.0.0.1:8080/apex, but Oracle 10g express working
    Johnny98 Newbie
    Currently Being Moderated
    Hello Again!
    FYI, I was able to load 10gXE on my laptop (from my office) today with no problem; but still no luck on my home pc! I think the issue must be during the install, it doesn't like my listener/tnsnames referencing host=stevens because when I install XE on my pc, the listener is not on until I manually change the listener to host=localhost.

    At the office, the listener has no problem after installation as the original host (mypc.mydomain.com).

    Anyways, here is my shared_server from my home pc:

    SQL> show parameter shared_server

    NAME TYPE VALUE
    ------------------------------------ ----------- -----------------
    max_shared_servers integer
    shared_server_sessions integer
    shared_servers integer 4

    Edited by: user3512717 on Aug 10, 2009 5:02 PM
  • 65. Re: Cannot open APEX http://127.0.0.1:8080/apex, but Oracle 10g express working
    438381 Guru
    Currently Being Moderated
    The shared_server setting looks to be fine.
    I still think your machine has a network issue which is preventing the listener from coming up on the external IP address
  • 66. Re: Cannot open APEX http://127.0.0.1:8080/apex, but Oracle 10g express working
    Johnny98 Newbie
    Currently Being Moderated
    Is that what the Microsoft Loopback adapter is supposed to remedy? When I installed it, it knocked out my internet connection completely...maybe I didn't set it up correctly.
  • 67. Re: Cannot open APEX http://127.0.0.1:8080/apex, but Oracle 10g express working
    Johnny98 Newbie
    Currently Being Moderated
    So this is interesting:

    Installed XE on laptop:
    -Connected at office, works
    -Connected at home, does not work
    -Connected at home but on VPN, DOES WORK!

    What the heck?
  • 68. Re: Cannot open APEX http://127.0.0.1:8080/apex, but Oracle 10g express working
    438381 Guru
    Currently Being Moderated
    So, the evidence for your home PC having a network issue mounts !
    What address does the listener listen on the VPN connection ?
    What do ipconfig & pint stevens show when on the VPN ?

    varad
  • 69. Re: Cannot open APEX http://127.0.0.1:8080/apex, but Oracle 10g express working
    Johnny98 Newbie
    Currently Being Moderated
    The issue must be with the Listener. It listens to the actual host (not localhost) when connected to VPN anc connects to XE. If I'm not on VPN, the only way Listener connects is with "localhost", but then it doesn't listen to XE! As you can see below, when on VPN, it says "Service "xe" has 1 instance(s)." which it doesn't do if not on VPN and host=localhost.

    Listener on VPN:
    LSNRCTL> stat
    Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=IPC)(KEY=EXTPROC_FOR_XE)))
    STATUS of the LISTENER
    ------------------------
    Alias LISTENER
    Version TNSLSNR for 32-bit Windows: Version 10.2.0.1.0 - Produ
    ction
    Start Date 12-AUG-2009 17:02:04
    Uptime 0 days 1 hr. 23 min. 25 sec
    Trace Level off
    Security ON: Local OS Authentication
    SNMP OFF
    Default Service XE
    Listener Parameter File C:\oraclexe\app\oracle\product\10.2.0\server\network\a
    dmin\listener.ora
    Listener Log File C:\oraclexe\app\oracle\product\10.2.0\server\network\l
    og\listener.log
    Listening Endpoints Summary...
    (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(PIPENAME=\\.\pipe\EXTPROC_FOR_XEipc)))
    (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=EISLHYBSBF1.acct02.us.lmco.com)(PORT
    =1522)))
    (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=127.0.0.1)(PORT=8080))(Presentation=
    HTTP)(Session=RAW))
    Services Summary...
    Service "CLRExtProc" has 1 instance(s).
    Instance "CLRExtProc", status UNKNOWN, has 1 handler(s) for this service...
    Service "PLSExtProc" has 1 instance(s).
    Instance "PLSExtProc", status UNKNOWN, has 1 handler(s) for this service...
    Service "XEXDB" has 1 instance(s).
    Instance "xe", status READY, has 1 handler(s) for this service...
    Service "XE_XPT" has 1 instance(s).
    Instance "xe", status READY, has 1 handler(s) for this service...
    Service "xe" has 1 instance(s).
    Instance "xe", status READY, has 1 handler(s) for this service...
    The command completed successfully

    IPCONFIG on VPN:
    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . : hsd1.co.comcast.net.
    IP Address. . . . . . . . . . . . : 192.168.1.102
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.1.1

    Ethernet adapter Wireless Network Connection:

    Media State . . . . . . . . . . . : Media disconnected

    Ethernet adapter {FF0C29B9-D901-4DD3-B8F5-7036209CA1F6}:

    Connection-specific DNS Suffix . :
    IP Address. . . . . . . . . . . . : 172.21.161.66
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 172.21.161.66

    PING the host on VPN:
    C:\Documents and Settings\stevninj>ping EISLHYBSBF1.acct02.us.lmco.com

    Pinging EISLHYBSBF1.acct02.us.lmco.com [172.21.161.66] with 32 bytes of data:

    Reply from 172.21.161.66: bytes=32 time<1ms TTL=128
    Reply from 172.21.161.66: bytes=32 time<1ms TTL=128
    Reply from 172.21.161.66: bytes=32 time<1ms TTL=128
    Reply from 172.21.161.66: bytes=32 time<1ms TTL=128

    Ping statistics for 172.21.161.66:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms
  • 70. Re: Cannot open APEX http://127.0.0.1:8080/apex, but Oracle 10g express working
    242945 Newbie
    Currently Being Moderated
    I had the identical problem, XE was working on VISTA but I couldn't access it via Internet Explorer.

    I have solved this by changing the url in the browser from
    http://127.0.0.1:8080/apex/
    to
    http://localhost:8080/apex/

    I made no changes except the above, though I had also already followed the install instructions at
    http://www.oracle.com/pls/xe102/homepage
    Installation Guide for Microsoft Windows HTML
    2.4.1 Configuring for Microsoft Internet Explorer
    so that might also be necessary, if you haven't done that.
  • 71. Re: Cannot open APEX http://127.0.0.1:8080/apex, but Oracle 10g express working
    Johnny98 Newbie
    Currently Being Moderated
    Varad,
    Since I am still unable to open the DB Home page (after a month now of trying everything), I had a friend install it on his machine at his home. He now has the same problem! He successfully installed 10gXE last week and was able to bring up the DB Home page upon initial installation. Now, a week later if he tries to access the home page he gets the "Internet Explorer Cannot Find Page"....UNBELIEVABLE! The issue appears to be widespread considering the number of entries on OTN regarding this scenario. Has this issue been fully diagnosed yet?
  • 72. Re: Cannot open APEX http://127.0.0.1:8080/apex, but Oracle 10g express working
    438381 Guru
    Currently Being Moderated
    Hi:

    Let me try the installation myself on a Vista box.

    Varad
  • 73. Re: Cannot open APEX http://127.0.0.1:8080/apex, but Oracle 10g express working
    Johnny98 Newbie
    Currently Being Moderated
    Varad,
    Have you been able to replicate the issue after your install on the Vista machine?
  • 74. Re: Cannot open APEX http://127.0.0.1:8080/apex, but Oracle 10g express working
    438381 Guru
    Currently Being Moderated
    John:

    No, not yet. Perhaps, sometime this week.

    Varad

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points