12 Replies Latest reply: Mar 19, 2010 7:25 AM by user76586 RSS

    Essbase server error

    710997
      Hi All,

      I m using Hyperion V11.1.1.1.0. I m able to start Essbase server but after a few second it is getting stopped automatically.

      I need your suggestion........
      Plz help.




      Thanks,
        • 1. Re: Essbase server error
          JohnGoodwin
          Hi,

          You can check the essbase.log which is in \Hyperion\logs\essbase
          You can also try starting it up from the start menu, this will display a command window and display any errrors.

          Start > Oracle EPM System > Essbase > Essbase Server > Essbase

          Cheers

          John
          http://john-goodwin.blogspot.com/
          • 2. Re: Essbase server error
            710997
            Hi John,


            Thanks for a quick reply.......

            I was doing in the same way as you said.That Essbase.cmd window also getting closed automatially.There is no error only one warning saying


            Log4j:WARN No appenders could be found for logger<com.hyperion.css.common.CSSLogger>
            log4j:WARN Please initialize the log4j system properly

            In ESSBASE.LOG it is showing the msg as below...

            [Tue Aug 04 14:52:03 2009]Local/ESSBASE0///Info(1051283)
            Retrieving License Information Please Wait...

            [Tue Aug 04 14:52:03 2009]Local/ESSBASE0///Info(1051286)
            License information retrieved.

            [Tue Aug 04 14:52:08 2009]Local/ESSBASE0///Info(1051199)
            Single Sign-On Initialization Succeeded !

            [Tue Aug 04 14:52:08 2009]Local/ESSBASE0///Info(1051232)

            Using English_UnitedStates.Latin1@Binary as the Essbase Locale

            And I tried http://<hss machine>:58080/interop/framework/getCSSConfigFile
            It is not working for me. I got this URL from another post of ur's.


            Thanks,
            • 3. Re: Essbase server error
              JohnGoodwin
              Hi,

              Make sure the essbase windows service is stopped, open a command prompt

              Go to the essbase bin directory e.g.

              cd C:\Hyperion\products\Essbase\EssbaseServer\bin

              Then run the following in the command window.

              call ".\setEssbaseEnv.cmd"
              set PATH=%ESSBASEPATH%;%PATH%
              %ESSBASEPATH%\bin\ESSBASE.exe %*

              This will start essbase in the same window and if you have any problems it will be outputted to the window and not closed automatically.

              Cheers

              John
              http://john-goodwin.blogspot.com/
              • 4. Re: Essbase server error
                710997
                Hi John,

                I got the error msg as below.


                Fatal Error: Fatal Error. The security file is corrupt. Use the backup file, ess
                base.bak, to replace essbase.sec. If the back up file is corrupted then use essb
                ase.bak_startup, that is taken every time you restart Essbase. You may also make
                use of essbase.bak_postUPM, the back up, that was taken just after migrating to
                Shared Services mode or essbase.bak_preUPM if the corruption happened while try
                ing to migrate to Shared Services mode.



                Thanks
                • 5. Re: Essbase server error
                  JohnGoodwin
                  Hi,

                  Have you taken a backup of your essbase directory recently, if so then you can just restore essbase.sec

                  Or you could try deleting essbase.sec and renaming ESSBASE.BAK to essbase.sec to see if that works.

                  Or deleting essbase.sec and renaming ESSBASE.BAK_postUPM to essbase.sec, though this will revert the essbase security/filters back to when you converted to shared services security mode.

                  Cheers

                  John
                  http://john-goodwin.blogspot.com/
                  • 6. Re: Essbase server error
                    700536
                    Hi John,

                    Not sure but i too am getting an error while starting Essbase service.

                    I tried what you had mentioned in your earlier post in this thread of starting essbase by using:

                    call ".\setEssbaseEnv.cmd"
                    set PATH=%ESSBASEPATH%;%PATH%
                    *%ESSBASEPATH%\bin\ESSBASE.exe %**

                    and i get the error below:

                    In Shared Services Security mode it is not possible to start Essbase when single
                    sign on initialization fails.

                    Fatal Error: Failed to start Essbase.

                    I then went in to chcek if my shared service was running well and figured out that OpenLDAP fails to start ... Below is the error message i get while trying to start OPen LDAP from Windows Services Panel:

                    Windows could not start the Hyperion Foundation OpenLDAP on Local Computer.For More Information, review the System Error Log. If this is a non- microsoft service , contact the service vendor , and refer to service specific error code 21.

                    Any help would be appreciated.

                    Kind Regards.

                    Alicia.

                    Edited by: Alicia on Aug 4, 2009 3:48 AM
                    • 7. Re: Essbase server error
                      710997
                      Thanks John,

                      I will try this......
                      • 8. Re: Essbase server error
                        JohnGoodwin
                        Alicia, the answer is covered [here |http://forums.oracle.com/forums/thread.jspa?messageID=3661320&#3661320] and Re: openLDAP does not get started...

                        Cheers

                        John
                        http://john-goodwin.blogspot.com/
                        • 9. Re: Essbase server error
                          700536
                          Thanks John..

                          I was just going through one of your blogs...

                          http://john-goodwin.blogspot.com/2008/08/bring-back-my-openldap.html

                          I must say you have done a great job with your blogs helping so many hyperion users.

                          Regards.

                          Alicia
                          • 10. Re: Essbase server error
                            716097
                            Hi John,

                            We had a similar issue today where the Essbase server agent would start but we could not log in to the server. Our logs would show that the agent starts but would freeze after single sign-on initialization succeeded. We restored our Essbase.sec files, but this did not fix our problem. Our log files show the following:
                            --------------------
                            [Thu Aug  6 08:12:56 2009]Local/ESSBASE0///Info(1051283)
                            Retrieving License Information Please Wait...

                            [Thu Aug  6 08:12:56 2009]Local/ESSBASE0///Info(1051286)
                            License information retrieved.

                            [Thu Aug  6 08:12:56 2009]Local/ESSBASE0///Info(1051227)
                            No JVM location specified in essbase.cfg. Will try to load from library path

                            [Thu Aug  6 08:12:58 2009]Local/ESSBASE0///Info(1051199)
                            Single Sign-On Initialization Succeeded !

                            [Thu Aug  6 08:12:58 2009]Local/ESSBASE0///Info(1051232)

                            Using English_UnitedStates.Latin1@Binary as the Essbase Locale
                            ---------------------------
                            We noticed that after we restarted Shared services, we were able to successfully login to the Essbase server and our applications loaded as well. Any idea what might be going on in Shared services that would stop us from being able to login to the Essbase server?

                            Thanks,
                            Karen
                            • 11. Re: Essbase server error
                              675027
                              Josephine wrote:
                              Hi All,

                              I m using Hyperion V11.1.1.1.0. I m able to start Essbase server but after a few second it is getting stopped automatically.

                              I need your suggestion........
                              Plz help.




                              Thanks,
                              We also encountered the essbase.sec corruption situation. However even we take the essbase.bak, we still find "outline mismatch" error after we resume the Essbase services.
                              • 12. Re: Essbase server error
                                user76586
                                RE Essbase Fatal Error, essbase.sec has to be restored. WHY IS THIS HAPPENING?