7 Replies Latest reply on Apr 13, 2010 5:33 AM by Fadi Samara Guest

    UTF8 database

    Dimitri Gielis

      I just wondered why the character set of the database on the Amazon machines is not UTF8?
      If you play with xmltype, the mswin character set is just not good...

      I don't seem to find any other threads having this problem. Aren't there any international folks using this then?


        • 1. Re: UTF8 database
          Hi Dimitri,

          I agree with you, we8mswin1252 is not good enouth... and it's strange that Oracle recommends the use of UTF8 unless you have a good reason not to use it!
          Are you using US based region?

          By the way, changing charset from mswin to utf8 is pretty straighfull if you haven't start using using the database... Usually there's only minor data conversion problems when you run csscan in a new database

          Joao Oliveira

          Edited by: Joao Oliveira on Sep 6, 2009 11:00 PM
          • 2. Re: UTF8 database

            they save disk space :)
            • 3. Re: UTF8 database
              Fadi Samara Guest
              All the databases posted on Amazon are non UTF8 which caused us a lot of trouble and wasting time.

              We have tried every way of converting the database and each time we stopped by a problem, none of oracle recommended solution worked on these AMI


              If we can't convert these databases to UTF8 then they are useless for us, and we have not find any solution so far!

              Could you please let us know how to get this issue resolved or whether you just considering add the UTF8 option to these AMIs?

              • 4. Re: UTF8 database
                Fadi Samara Guest
                we just tried full import and export for the database to UTF8 and didn't work!

                We need a solution for this?

                • 5. Re: UTF8 database
                  bill hodak - oracle

                  Please tell us what AMI-ID you are using and paste the errors you get when trying to convert your character set. If this is a new ec2 instance and you haven't already added your own data to the database, then your best bet may be to just create a new database with your preferred characterset using dbca.

                  • 6. Re: UTF8 database
                    Fadi Samara Guest
                    Hi Bill,

                    When using alter character set the error not a subset.

                    When using alter character set with internal_use the database will be corrupted.

                    When using csscan and csalter the error will be unrecognized convertible date found in scanner result.

                    When using Import/Export the error IMP-00016 Required Character Set Conversion Not Supported Error when Import to Oracle Database.

                    I have tried to run the dbca but there is no character/nls_lang choice in this script.

                    The AMI ami-7596bd01, and this happens with all Oracle AMIs.

                    Please note that all these happened just after we created the database prior to any database transactions/alterations.
                    Please give us a solution we just can't proceed any more.

                    • 7. Re: UTF8 database
                      Fadi Samara Guest
                      Is there a difference between UTF8 and AL32UTF8?

                      We have upload issue, with the following

                      apex 3.2.1

                      After upload (UTF8) XML file to (AL32UTF8) apex application database table, no data will be populated at all. The web page shows normal upload process with no fail notifications.