1 2 3 Previous Next 40 Replies Latest reply on Feb 4, 2011 4:23 PM by Andy Steel Go to original post
      • 30. Re: ORA-12547: TNS: lost contact
        447699
        Thanks to God.

        I solve the problem of ORA-12547: TNS: lost contact

        Now the database and database listner are running and

        Oracle eBusiness Suite R12.1 is working fine on Enterprise Linux 5.3

        Ali
        • 31. Re: ORA-12547: TNS: lost contact
          EdStevens
          user444696 wrote:
          Thanks to God.

          I solve the problem of ORA-12547: TNS: lost contact

          Now the database and database listner are running and

          Oracle eBusiness Suite R12.1 is working fine on Enterprise Linux 5.3

          Ali
          So what was the solution that you found?
          • 32. Re: ORA-12547: TNS: lost contact
            447699
            Yes you are right

            I know I have to post how I solved the problem.

            I took different trails and read different websites

            I have to go back and write down the step I took and the website addresses I refered

            and will post the answer

            Ali
            • 33. Re: ORA-12547: TNS: lost contact
              user649511
              Any update on how you resolved this?
              • 34. Re: ORA-12547: TNS: lost contact
                440701
                Hi,

                check your kernel settings. it must be exact the same as Oracle needs in pre installation tasks.

                SHD
                • 35. Re: ORA-12547: TNS: lost contact
                  user649511
                  sb92075, Since it looks like OP is not willing to provide the solution to their problem I guess i will take it upon myself to thank you for trying to help and guide them. I'm betting that your comments and suggestions provide the path to the solution that was found. Too bad it won't be acknowledged by th OP. If I could I would give you pionts for your effort and patience.
                  • 36. Re: ORA-12547: TNS: lost contact
                    508274
                    could you please write the needed step to resolve this problem

                    Regards
                    • 37. Re: ORA-12547: TNS: lost contact
                      695064
                      I am having this problem as well on 11gR2 on Linux 5. I was directed by support personnel to reconfigure HAS and now I can't start up the database because of this issue. Does anyone have any ideas?
                      • 38. Re: ORA-12547: TNS: lost contact
                        Andy Steel
                        Thanks,

                        i've been through both metalink items and related posts off these and none of the recommendations or suggestions have made any difference.

                        Still getting TNS contact lost error.

                        Isn't there a logfile that I could turn on anywhere to help ? listener trace file only seems to output when listener is starting.

                        Just to recap
                        a) the oracle process runs
                        b) the listeners start ok
                        c) sqlplus runs, but gets error when try to connec.

                        I can run SQLPLUS /NOLOG and there is no error, but as soon as i try CONNECT it'll fail.

                        Really stumped and thinking about trashing Oracle Linux and going to Redhat ES 64-bit
                        • 39. Re: ORA-12547: TNS: lost contact
                          ivwvi
                          Are you able to connect TO DATABASE remotely?
                          • 40. Re: ORA-12547: TNS: lost contact
                            Andy Steel
                            In short no.

                            In long....
                            Since I am unable to connect locally, in order to create a database(kcom) & users, i therefore cannot connect remotely as have no user schema to connect as.

                            I can connect to ANOTHER oracle host ("LTEST2") from my TOAD windows client by using username & password of SYS/SYS and then selecting SYSDBA.

                            If I try same but for this 64-bit host it fails with ORA-12514: TNS:listener does not currently know of service requested in connect descriptor. That's when trying to connect using TNS. If I try and connect using SID of Rialto then I get ORA-12537: TNS:connection closed

                            The configuration of TNSNAMES.ORA is identical on windows machines between the two systems.

                            ltest2 =
                            (DESCRIPTION =
                            (ADDRESS_LIST =
                            (ADDRESS =
                            (PROTOCOL = TCP)
                            (HOST = ltest2)
                            (PORT = 1521)
                            )
                            )
                            (CONNECT_DATA =
                            (SERVER = SHARED)
                            (SERVICE_NAME = kcom.world)
                            )
                            )

                            ora64 =
                            (DESCRIPTION =
                            (ADDRESS_LIST =
                            (ADDRESS =
                            (PROTOCOL = TCP)
                            (HOST = ora64.kcom.com)
                            (PORT = 1521)
                            )
                            )
                            (CONNECT_DATA =
                            (SERVER = shared)
                            (SERVICE_NAME = kcom.world)
                            )
                            )


                            This is the listener.ora on the 64-bit server.

                            SID_LIST_LISTENER =
                            (SID_LIST =
                            (SID_DESC =
                            (SID_NAME = PLSExtProc)
                            (ORACLE_HOME = /u01/app/oracle/product/11.1.0)
                            (PROGRAM = extproc)
                            )
                            (SID_DESC =
                            (SID_NAME = Rialto)
                            (ORACLE_HOME = /u01/app/oracle/product/11.1.0)
                            )
                            )

                            LISTENER =
                            (DESCRIPTION_LIST =
                            (DESCRIPTION =
                            (ADDRESS = (PROTOCOL = TCP)(HOST = ora64.kcom.com)(PORT = 1521))
                            )
                            )

                            DIRECT_HANDOFF_TTC_LISTENER = OFF
                            INBOUND_CONNECT_TIMEOUT_LISTENER = 5
                            TRACE_LEVEL_LISTENER=6
                            1 2 3 Previous Next