1 2 Previous Next 19 Replies Latest reply: Oct 27, 2009 8:31 PM by 730560 RSS

    BUG: Oracle XE installation to Ubuntu

    jariola
      Hi

      I have found that there is problems with Oracle XE on Ubuntu if you do not answer 'y' to question "Do you want Oracle Database 10g Express Edition to be started on boot" when running
      /etc/init.d/oracle-xe configure
      after installation.

      If you have selected 'n' commands
      /etc/init.d/oracle-xe start
      /etc/init.d/oracle-xe stop
      do not work anymore.

      Fix that issue open file /etc/default/oracle-xe
      sudo nano /etc/default/oracle-xe
      and change line
      ORACLE_DBENABLED=false
      to
      ORACLE_DBENABLED=true
      Then database is started on boot and commands
      /etc/init.d/oracle-xe start
      /etc/init.d/oracle-xe stop
      start working.

      Problem is also even what options you use when configure XE,
      icon/link "Start Database" placed to menu bar do not start XE HTTP server.
      Thats why you can not connect to Apex even database is running.
      Unfortunately I do not have workaround for that.

      Br, Jari

      Edited by: jarola on Aug 16, 2009 9:48 PM
        • 1. Re: BUG: Oracle XE installation to Ubuntu
          717572
          try to edit your ~/.bashrc

          ORACLE_HOME=/usr/lib/oracle/xe/app/oracle/product/10.2.0/server
          PATH=$PATH:$ORACLE_HOME/bin
          export ORACLE_HOME

          ... and reboot

          for me working like a dream .. on 32bit and 64bit ubuntu as well...

          Good luck buddy!
          • 2. Re: BUG: Oracle XE installation to Ubuntu
            jariola
            Hi

            Thanks,
            Problem is not in environment variables.
            And my post is for persons that having problems. I do not have =)

            PS: Set env variables and try install XE so that it is not automatically startup during boot, you will see.

            Br, Jari

            Edited by: jarola on Aug 16, 2009 10:55 PM / typo

            Edited by: jarola on Aug 16, 2009 10:55 PM
            • 3. Re: BUG: Oracle XE installation to Ubuntu
              jariola
              Hi

              If you like test this

              Do this
              sudo nano /etc/default/oracle-xe
              and change line
              ORACLE_DBENABLED=true
              to
              ORACLE_DBENABLED=false
              Reboot and post your results.

              Br, Jari
              • 4. Re: BUG: Oracle XE installation to Ubuntu
                717572
                Hi,

                I did it, if I change to "false" the database does not load at the startup.
                http://127.0.0.1:8080/apex does not work.

                It's true again ... and working.

                hope I could help

                Regards,
                Roland

                Edited by: user1093960 on Aug 16, 2009 1:25 PM
                • 5. Re: BUG: Oracle XE installation to Ubuntu
                  jariola
                  Hi

                  Thanks,

                  But can you start it from menu bar Start Database or by command
                  sudo /etc/init.d/oracle-xe start
                  If value is false and you have rebooted

                  Br, Jari

                  Edited by: jarola on Aug 16, 2009 11:28 PM
                  • 6. Re: BUG: Oracle XE installation to Ubuntu
                    717572
                    yes I could start from command line
                    by the sudo /etc/init.d/oracle-xe start command
                    just have not started automatic

                    Regards,

                    Roland

                    Edited by: user1093960 on Aug 16, 2009 1:52 PM
                    • 7. Re: BUG: Oracle XE installation to Ubuntu
                      jariola
                      Hi

                      Thanks,

                      And Apex works ?
                      Does HTTP server start from menu bar icon/link "Start Database" ?

                      What version of Ubuntu you use ?

                      I did find this problem when on Ubuntu 9.04.
                      I do not remember did I have any on older release

                      Br, Jari
                      • 8. Re: BUG: Oracle XE installation to Ubuntu
                        717572
                        I'm on 9.04 32bit now and apex works as well. I can start the server from menu bar icon/link "Start Database".

                        by icon/link may you get a "operation failed , xxxx is not a member of "dba" group." error.
                        Solution: System - Administration - Users and Groups
                        Manage groups - choose "dba" - properties and then check that your are member of the "dba" group or not.

                        On 9.04 64bit I had similar problem.. with oracle xe and enterprise as well) the database did not work and start automatic (anymore after the first reboot)
                        I spent so many time to try oracle database on ubuntu 9.04 64 bit but does not work for me.
                        On 9.04 32 bit working like a dream.

                        Good luck Jari!

                        Let me know how you solved the problem!

                        Regards,

                        roland

                        Edited by: user1093960 on Aug 16, 2009 2:58 PM
                        • 9. Re: BUG: Oracle XE installation to Ubuntu
                          717572
                          here is my oracle-xe file { ORACLE_DBENABLED=true } now.


                          #This is a configuration file for automatic starting of the Oracle
                          #Database and listener at system startup.It is generated By running
                          #'/etc/init.d/oracle-xe configure'.Please use that method to modify this
                          #file

                          # ORACLE_DBENABLED:'true' means to load the Database at system boot.
                          ORACLE_DBENABLED=true

                          # LISTENER_PORT: Database listener
                          LISTENER_PORT=1521

                          # HTTP_PORT : HTTP port for Oracle Application Express
                          HTTP_PORT=8080

                          # Configuration : Check whether configure has been done or not
                          CONFIGURE_RUN=true
                          • 10. Re: BUG: Oracle XE installation to Ubuntu
                            jariola
                            Hi

                            Thanks,
                            I do not get that error because I'm on DBA group.

                            So you say if /etc/default/oracle-xe is set
                            ORACLE_DBENABLED=false
                            and then reboot.
                            Then you can use command ok
                            sudo /etc/init.d/oracle-xe start
                            and menu bar link "start database" start your XE HTTP server and connect to Apex work ?



                            It is strange that I and my friends get this problem if /etc/default/oracle-xe is set.
                            ORACLE_DBENABLED=false
                            Also when doing OS clean install and then install XE from
                            deb http://oss.oracle.com/debian unstable main non-free
                            Well, I'm not suffer because I need start database on boot time.

                            PS: we do sudo aptitude install oracle-xe-universal from that repo
                            Br, Jari

                            Edited by: jarola on Aug 17, 2009 1:18 AM
                            • 11. Re: BUG: Oracle XE installation to Ubuntu
                              jariola
                              Hi

                              May I ask you do this test:

                              Stop your database
                              sudo /etc/init.d/oracle-xe stop
                              Change on /etc/default/oracle-xe
                              ORACLE_DBENABLED=false
                              Then
                              sudo /etc/init.d/oracle-xe start
                              What is output to terminal ?

                              Br, Jari
                              • 12. Re: BUG: Oracle XE installation to Ubuntu
                                jariola
                                Hi

                                I did find why menu bar link "Start Database" did not work.
                                On default install from repo, DBA group do not have write permission to file
                                /usr/lib/oracle/xe/app/oracle/product/10.2.0/server/network/log/listener.log

                                To fix that
                                sudo chmod g+w /usr/lib/oracle/xe/app/oracle/product/10.2.0/server/network/log/listener.log
                                Br, Jari
                                • 13. Re: BUG: Oracle XE installation to Ubuntu
                                  717572
                                  Hi,

                                  it's strange now ... with
                                  sudo /etc/init.d/oracle-xe stop
                                  command does not stop my database. But I could stop by icon/link "stop database"
                                  well, I did it.
                                  After I changed on /etc/default/oracle-xe
                                  ORACLE_DBENABLED=false
                                  ..after
                                  roland@wst:~$sudo /etc/init.d/oracle-xe start
                                  roland@wst:~$
                                  nothing output to terminal.. does not work

                                  but with ...
                                  roland@wst:~$ sudo /etc/init.d/oracle-xe restart
                                  Shutting down Oracle Database 10g Express Edition Instance.
                                  Stopping Oracle Net Listener.
                                  
                                  Starting Oracle Net Listener.
                                  Starting Oracle Database 10g Express Edition Instance.
                                  everything working fine http://127.0.0.1:8080/apex ...

                                  Regards,
                                  roland
                                  • 14. Re: BUG: Oracle XE installation to Ubuntu
                                    jariola
                                    Hi

                                    Thanks,

                                    What I can see if /etc/default/oracle-xe is set
                                    ORACLE_DBENABLED=false
                                    what is option value when you select that database should not start on system startup,
                                    command
                                    /etc/init.d/oracle-xe
                                    does not work at all.

                                    If you start database it means database is not closed and shutdown right way on system shutdown.
                                    So you should first shutdown database and stop listener before shutdown whole system.

                                    Workaround for that
                                    sudo cp /etc/init.d/oracle-xe /etc/init.d/shutdown-xe
                                    sudo update-rc.d shutdown-xe stop 20 0 1 6 .
                                    sudo chmod -x /etc/init.d/oracle-xe
                                    sudo chmod g+w /usr/lib/oracle/xe/app/oracle/product/10.2.0/server/network/log/listener.log
                                    sudo usermod -a -G dba your_username
                                    Notice that "your_username" is user that you like allow to start database

                                    And
                                    change /etc/default/oracle-xe to
                                    ORACLE_DBENABLED=true
                                    Edit:
                                    So above workaround is if you do not want start DB on system startup.
                                    There is no problem if you have selected during install that DB is started automatically.

                                    If you use above workaround and change you mind that DB should start when you start system then just do
                                    sudo chmod +x /etc/init.d/oracle-xe
                                    sudo update-rc.d -f shutdown-xe remove
                                    sudo rm /etc/init.d/shutdown-xe
                                    Br ,Jari

                                    Edited by: jarola on Aug 17, 2009 2:58 AM

                                    Edited by: jarola on Aug 17, 2009 3:12 PM / changed update-rc.d shutdown-xe
                                    1 2 Previous Next