11 Replies Latest reply on Nov 12, 2012 9:22 AM by 973750

    Error in starting opmn server

    717762
      Hello,

      Note: I posted this thread on the Identity Management forum as well. I wanted to post it here too, as I think my problem may be a more generic Application Server one, instead of one specific to Identity Management. If this is improper etiquette, I apologize.

      I have a VM, which is being administered by VMware Lab Manager. The VM is running RHEL 5.1, and has an Oracle 11g database installed.

      I am in the process of trying to install and configure Oracle Internet Directory 11g. To do this, I ran the Oracle Fusion Middleware 11g Oracle Identity Management Installer. I selected the "Install Software - Do Not Configure" installation type, and chose to "Configure without a Domain" in order to avoid having to install and administer a WebLogic domain. I set "/data1/u01/app/oracle/product/11.1.1" as the Oracle Middleware Home, and "Oracle_IDM1" as the Oracle Home Directory. (To simplify things below, let ORACLE_IDM_HOME refer to the /data1/u01/app/oracle/product/11.1.1/Oracle_IDM1" directory... understand that no environment variable exists with this name though.) The installation routine ran successfully.

      But, I ran into a problem while trying to configure the Oracle Identity Management 11g components. I ran the Oracle Identity Management 11g Release 1 Configuration Wizard (ORACLE_IDM_HOME/bin/config.sh). Here are some of the key configuration values that I entered:

      - Oracle Instance Location: /data1/u01/config/oracle/as_admin/asinst_1
      - Oracle Instance Name: asinst_1
      - Select Domain: Configure without a Domain
      - Configure Components: Oracle Internet Directory
      - Configure Ports: Auto Port Configuration
      - Specify Schema Database: Create Schema

      After entering my configuration values and hitting the Configure button, the configuration process started running. Shortly thereafter, under Bootstrap Domain Configuration, "Failed" appeared next to the "Create ASInstance" line, with the following error listed:

      {code}
      Error creating ASInstance asinst_1
      Cause: An internal operation has failed: Error in starting opmn server
      Operation aborted because of a system call failure or internal error
      {code}

      In case it would be helpful, here is the output from the error log for the Oracle Identity Management 11g Configuration Wizard:

      {code}
      oracle.as.provisioning.util.ConfigException:
      Error creating ASInstance asinst_1.
      Cause:
      An internal operation has failed: Error in starting opmn server
      Operation aborted because of a system call failure or internal error
      Action:
      See logs for more details.
      at oracle.as.provisioning.util.ConfigException.createConfigException(ConfigException.java:123)
      at oracle.as.provisioning.fmwadmin.ASInstanceProv._createInstance(ASInstanceProv.java:306)
      at oracle.as.provisioning.fmwadmin.ASInstanceProv.createInstance(ASInstanceProv.java:163)
      at
      oracle.as.provisioning.fmwadmin.ASInstanceProv.createInstanceAndComponents(ASInstanceProv.java:114)
      at
      oracle.as.provisioning.engine.WorkFlowExecutor._createASInstancesAndComponents(WorkFlowExecutor.java:533)
      at
      oracle.as.provisioning.engine.WorkFlowExecutor.executeWLSWorkFlow(WorkFlowExecutor.java:437)
      at oracle.as.provisioning.engine.Config.executeConfigWorkflow_WLS(Config.java:870)
      at oracle.as.provisioning.engine.Config.executeConfigWorkflow_WLS(Config.java:824)
      at oracle.as.idm.install.config.BootstrapConfigManager.doExecute(BootstrapConfigManager.java:1256)
      at
      oracle.as.install.engine.modules.configuration.client.ConfigAction.execute(ConfigAction.java:335)
      at
      oracle.as.install.engine.modules.configuration.action.TaskPerformer.run(TaskPerformer.java:87)
      at
      oracle.as.install.engine.modules.configuration.action.TaskPerformer.startConfigAction(TaskPerformer.java:104)
      at oracle.as.install.engine.modules.configuration.action.ActionRequest.perform(ActionRequest.java:15)
      at
      oracle.as.install.engine.modules.configuration.action.RequestQueue.perform(RequestQueue.java:63)
      at
      oracle.as.install.engine.modules.configuration.standard.StandardConfigActionManager.start(StandardConfigActionManager.java:158)
      at
      oracle.as.install.engine.modules.configuration.boot.ConfigurationExtension.kickstart(ConfigurationExtension.java:81)
      at
      oracle.as.install.engine.modules.configuration.ConfigurationModule.run(ConfigurationModule.java:82)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: oracle.as.management.opmn.optic.OpticException: Error in starting opmn server
      Operation aborted because of a system call failure or internal error
      at oracle.as.management.opmn.optic.OpmnAdmin.executeCommand(OpmnAdmin.java:255)
      at oracle.as.management.opmn.optic.OpmnAdmin.startOpmnServer(OpmnAdmin.java:87)
      at oracle.as.provisioning.fmwadmin.ASInstanceProv._createInstance(ASInstanceProv.java:251)
      ... 16 more
      {code}

      To get more information, I tried to manually start the opmn server (I set ORACLE_INSTANCE to "/data1/u01/config/oracle/as_admin/asinst_1" and then ran "./opmnctl start" from the ORACLE_IDM_HOME/opmn/bin directory). As expected, the server failed to start. But, I checked the opmn.out file (in the ORACLE_INSTANCE/diagnostics/logs/OPMN/opmn directory), and found the following error repeated several times:

      {code}
      OPMN worker process exited with status 8b. Restarting.
      OPMN worker process exited with status 8b. Restarting.
      ...
      OPMN worker process terminated with signal 11 7 times in 10 seconds -- aborting!
      {code}

      Does anyone know what this error means? I am at a loss as to what to do at this point, so any help would be greatly appreciated.

      Thank you!