1 Reply Latest reply on Sep 12, 2009 3:17 AM by APC

    csdkjni.dll cannot find dependencies

      Well this is probably a long shot since no one has posted here in months... Wonder why Oracle? You only make it damn near impossible to find or get the SDK let alone provide reasonable documentation for preparing the development environment. Okay, I'm obviously frustrated.

      Here is the problem (trying to run CSDKDemo):

      Exception in thread "main" java.lang.UnsatisfiedLinkError: C:\product\10.1.2\ocs_1\ocal\lib\csdkjni.dll: Can't find dependent libraries
           at java.lang.ClassLoader$NativeLibrary.load(Native Method)
           at java.lang.ClassLoader.loadLibrary0(Unknown Source)
           at java.lang.ClassLoader.loadLibrary(Unknown Source)
           at java.lang.Runtime.loadLibrary0(Unknown Source)
           at java.lang.System.loadLibrary(Unknown Source)
           at oracle.calendar.sdk.Api.loadJniLib(Unknown Source)
           at oracle.calendar.sdk.Api.init(Unknown Source)
           at calendardemo.CalendarSession.init(CalendarSession.java:46)
           at calendardemo.CalendarSession.<init>(CalendarSession.java:26)
           at calendardemo.CSDKDemo.main(CSDKDemo.java:23)

      I've search and looked through every thread, every JNI troubleshooting page, used dependency walker on csdkjni.dll, etc.

      I'm trying to compile this in eclipse IDE, on Windows XP. Here is my VM command line argument:

      The jlib and bin directories are there because I saw the suggestion somewhere in my searching. Everything works the same with just the lib directory also. It's obviously finding the csdk.jar and it's finding csdkjni.dll also, but not one of its dependencies. According to dumpbin.exe it's dependencies are:


      Everything is found when I run dependency walker. capi.dll is located in the same directory as csdkjni.dll. This directory has been added to my system's PATH environment variable. I've also tried putting capi.dll in every folder I could think of with no luck. I'm totally out of ideas and cannot believe I've lost an entire day just trying to get the demo to compile. Does ANYONE have a clue whats going on here?

      Is it possible that this error message is just not correct and that its actually having a problem loading some function from the DLL?