This discussion is archived
4 Replies Latest reply: Mar 12, 2010 5:05 AM by EdStevens RSS

Oracle 11g database link to Oracle 8

722238 Newbie
Currently Being Moderated
Hi,

database-links from an Oracle 11g to an Oracle 8-Database seem to do not work:

The error in enterprise manager is: socket error (translated from german).
There are no alerts at the Oracle 11g-Database.
On the other (Oracle 8) side, the alert we have is an "internal error"

Has anybody else that experience, and maybe a solution?

Thx a lot for your help
Alex
  • 1. Re: Oracle 11g database link to Oracle 8
    Justin Cave Oracle ACE
    Currently Being Moderated
    "Oracle 8" could mean a lot of things from 8.0.4 to 8.1.7.

    But 11.1 was never certified to connect to a version of the database older than 9.2. So I wouldn't expect this to work. You could potentially set up a separate 9.2 database that the 11.1 database could connect to and that could then connect to the "Oracle 8" database if "Oracle 8" means 8.1.7 or 8.0.6. If "Oracle 8" means something older than that, you'd have to end up making two hops (i.e. 11.1 to 9.2 to 8.1.7 to 8.0.5).

    Justin

    Edited by: Justin Cave on Sep 12, 2009 4:04 PM

    In addition to setting up an intermediate database, you could potentially also use Heterogeneous Services and the ODBC Gateway to configure a database link between the two databases. That will require installing the ODBC gateway on a machine that has a sufficiently old version of the Oracle client and configuring an ODBC connection to the "Oracle 8" database.
  • 2. Re: Oracle 11g database link to Oracle 8
    hans forbrich Oracle ACE Director
    Currently Being Moderated
    Subject:      Client / Server / Interoperability Support Between Different Oracle Versions
    Doc ID:      207303.1

    says 'Not compatible'. Use a 9.2.0.8 as an intermediary.
  • 3. Oracle 11g and 10g database links
    693980 Newbie
    Currently Being Moderated
    Hi All,

    I have a DB link called "appdb.message.oracle.com".

    In 10g "select * from table@appdb;" is working fine but in 11g not.

    Why so?

    In 11g if i create DB link with the name "appdb" only then the query "select * from table@appdb;" is working fine.

    Is there any update in 11g regarding this DB link names.

    Plz help me out..

    Thanks in Advance,
    Sridhar
  • 4. Re: Oracle 11g and 10g database links
    EdStevens Guru
    Currently Being Moderated
    user10956040 wrote:
    Hi All,
    Why are you hijacking someone else's thread? This just makes it harder to deal with the OP's issue, even if you think it is closely related to yours, and you haven't given any indication that it is at all related.
    I have a DB link called "appdb.message.oracle.com".

    In 10g "select * from table@appdb;" is working fine but in 11g not.

    Why so?
    I have two cars in my garage. One works. One doesn't. Why so?

    Some description of "not working" would be helpful. Actual ora-nnnnn error messages even more so.

    In 11g if i create DB link with the name "appdb" only then the query "select * from table@appdb;" is working fine.

    Is there any update in 11g regarding this DB link names.

    Plz help me out..
    Help us to help you by giving us some clues. Given my comments above, preferably in your own thread.
    Thanks in Advance,
    Sridhar

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points