8 Replies Latest reply: Jan 28, 2010 3:13 PM by 749957 RSS

    Deploying P3 in Citrix

    723781
      Due to issues with Windows Vista, we're experimenting with deploying P3 over Citrix. The only problem we're running into is that the menus don't work. For example, if you click on the 'File' menu, the menu doesn't drop down. The toolbar icons work just fine, but the menus do not work.

      Anybody have any ideas?
        • 1. Re: Deploying P3 in Citrix
          jkleinman
          user8096967 wrote:
          Due to issues with Windows Vista, we're experimenting with deploying P3 over Citrix. The only problem we're running into is that the menus don't work. For example, if you click on the 'File' menu, the menu doesn't drop down. The toolbar icons work just fine, but the menus do not work.

          Anybody have any ideas?
          I have installed/configured P3 on quite a few Citrix servers and never ran into this before.

          How are you connecting? (Published application, published desktop, etc) If you connect to the server via RDP does everything work as normal?

          I sounds like a graphics problem. Have you tried to experiment with the various graphics settings available when connecting?
          • 2. Re: Deploying P3 in Citrix
            723781
            We're publishing just the application, not the desktop. This is also the same server where we have deployed P6.

            If I RDP onto the server it works just fine. What kind of graphics settings would you suggest?

            Thank you for your help

            Brooks Williams
            • 3. Re: Deploying P3 in Citrix
              jkleinman
              user8096967 wrote:
              We're publishing just the application, not the desktop. This is also the same server where we have deployed P6.

              If I RDP onto the server it works just fine. What kind of graphics settings would you suggest?

              Thank you for your help

              Brooks Williams
              When you publish the app you have the window with all the session settings like size of the window, colors, etc.

              What did you set this to? I usually select True Color (24 bit) but it's possible that's causing issues, and P3 doesn't really use that many colors so try to play with that setting and see what happens.
              • 4. Re: Deploying P3 in Citrix
                723781
                Thanks for the help.

                I talked my my IT department and they're telling me that they tried multiple color settings, resolutions, etc. Nothing seems to resolve the problem. What's weird is that if you just use the icons in the toolbars you can still open a schedule and do all sorts of things - but that stupid file menu never does anything.
                • 5. Re: Deploying P3 in Citrix
                  lquintino
                  Have you tried configuring P3 to run as on Windows 2000 or Xp, using the properties of the EXE?
                  It solve me a lot of problems on Terminal server.
                  Luís
                  • 6. Re: Deploying P3 in Citrix
                    cruz878
                    Not sure if this is relevant to your specific problem but make sure you are running Service Pack 3 for P3.1.
                    • 7. Re: Deploying P3 in Citrix
                      725276
                      Having the same problem. everything works but the file tools bar, icon tool bar works fine.
                      • 8. Re: Deploying P3 in Citrix
                        749957
                        Did anyone ever find the resolution to this problem? I just got P3 running in Citrix PS 4.5 and can't seem to get the file menu to drop down.