7 Replies Latest reply on Nov 1, 2012 12:18 PM by Steven Davelaar-Oracle

    Cannot run forms2ADF generator

      We are using JHS11gTP with Jdev 11g

      I am trying to run the forms2adf generator in JDEveloper. I select an .fmb file and then i get a validation failed message saying

      *"Oracle Forms needs to be installed on this machine to process forms .fmb files*
      *To process form modules without oracle forms installed you should first run the frmf2xml utility with command line argument 'USE_PROPERTY_IDS=YES' on a machien with forms installed, and then select the .xml files created by this utility here."*

      First of all, i do have forms installed on my machine. So i am not sure why I am getting the message above. Is there anyway i can configure JHS plugin to point it to the forms environment/exe etc.?

      Issue 2
      Secondly, when i do run the the Forms2XML utliity with -DUSE_PROPERTY_IDS=yes, i still get the same message. What should i be doing?

      C:\jdev_workspace\11g_workspace\\JHS>D:\IDS_10g2\jdk\bin\java -classpath D:\IDS_10g2\forms\java\frmxmltools.jar;D:\IDS_10g2\forms\java\frmjdapi.jar;D:\IDS_10g2\lib\xmlparserv2.jar;D:\IDS_10g2\lib\xschema.jar  -DUSE_PROPERTY_IDS=yes -DOVERWRITE=YES oracle.forms.util.xmltools.Forms2XML myform.fmb

      I was able to run Forms2XML utliity using the following format. Still i need to find why I cannot use JDeveloper to take an fmb file and convert it to JHS (First Issue).

      D:\IDS_10g2\BIN\frmf2xml.bat USE_PROPERTY_IDS=yes form.fmb

      I would appreciate your help in this regard.


      Edited by: user11219846 on Sep 29, 2009 3:06 PM
        • 1. Re: Cannot run forms2ADF generator
          Steven Davelaar-Oracle
          We test whether Forms is installed by using a command that is also used by the frmf2xml utility:


          You could make your own java class with this statement (you need to import oracle.forms.jdapi.Jdapi), and add the frmjdapi.jar and frmxmltools.jar files to the project, and see what happens. These jar files can be found in [jdev_home]\jdev\extensions\oracle.jheadstart.11.1.1\designtime\lib

          Steven Davelaar,
          JHeadstart Team.
          • 2. Re: Cannot run forms2ADF generator
            Thanks for your email. Extending and writing a class will not fix Issue#1 though (i.e. making sure the JHS wizard works smoothly). Let me know if i misunderstood and what I missed.
            • 3. Re: Cannot run forms2ADF generator
              Steven Davelaar-Oracle
              Well, making this class and running this will help us finding out the cause of issue 1.
              The JHS wizard thinks Forms is not installed, while it is.
              By running the same code that checks for Forms install outside JHS wizard in your own class, we can try to isolate the problem.

              Steven Davelaar,
              JHeadstart Team.
              • 4. Re: Cannot run forms2ADF generator
                I tried Jdapi.setFailSubclassLoad(true); and opening the module. JDev console is saying that

                Exception in thread "main" java.lang.UnsatisfiedLinkError: D:\IDS_10g2\BIN\frmjapi.dll: The specified procedure could not be found
                     at java.lang.ClassLoader$NativeLibrary.load(Native Method)

                But I can clearly see this dll being in the above mentioned directory. I have sent those two screenshots to you.
                • 5. Re: Cannot run forms2ADF generator

                  in Forms2ADF select xml file, not fmb. This work.

                  • 6. Re: Cannot run forms2ADF generator
                    I had similar issue today. I tried the suggestion of running Jdapi.setFailSubclassLoad(true); in a separate java class to see the error. The error I was getting was

                    Exception in thread "main" java.lang.UnsatisfiedLinkError: C:\Oracle\OracleForms11gR2\Oracle_FRHome1\bin\frmjapi.dll: Can't load AMD 64-bit .dll on a IA 32-bit platform
                         at java.lang.ClassLoader$NativeLibrary.load(Native Method)
                         at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1806)
                         at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1731)
                         at java.lang.Runtime.loadLibrary0(Runtime.java:823)
                         at java.lang.System.loadLibrary(System.java:1028)
                         at oracle.forms.jdapi.Jdapi.<clinit>(Unknown Source)
                         at model.Test.main(Test.java:12)
                    Process exited with exit code 1.

                    The reason was that my operating system is windows 7 64 bit and I installed the 64 bit version of Oracle Forms on my machine. However, the jdeveloper installation was using a 32 bit java. So, I changed my Jdeveloper to use the 64 bit java in the jdev.conf file and then it worked.
                    • 7. Re: Cannot run forms2ADF generator
                      Steven Davelaar-Oracle
                      Thanks for updating the post with this useful info, good bear! :-)
                      In the next release, we will update the error message with this info.

                      Steven Davelaar,
                      JHeadstart Team.