3 Replies Latest reply on Oct 6, 2009 3:56 AM by 385818

    Sun JRE 1.6.0_16

    sky123
      Hi,

      We use dynamic versioning in Forms with the default jpi_classid for JRE 1.4. We didn't change this default value. Then, on my PC, I only installed Sun JRE 1.6.0_16. When I ran the Forms applications, it didn't prompt me for JRE 1.4. Instead, it used the installed JRE 1.6.0_16. Is this how dynamic versioning works?

      From my understanding, if I point jpi_classid to the JRE 1.4 family, the client has to have any version of JRE 1.4. In order for Forms to use any update of JRE 1.6, I must specify the JRE 1.6 family. Is it correct?

      My PC is Windows XP. There are many different OS like Vista, XP, 2000...maybe Windows 7 later. I need to make sure what exactly I should enter for "jpi_classid" if I want all the clients to use JRE 1.6.

      Thanks.
      Andy
        • 1. Re: Sun JRE 1.6.0_16
          385818
          This question is nicely answered in this thread - Any changes in formsweb.cfg ?

          Also, there is additional info here: http://www.oracle.com/technology/products/forms/htdocs/10gR2/howto/forms_jre.pdf

          You mentioned OS but missed to mentioned the most important thing which is the browser, so what browser is it that you're planning to use ?

          Ref. default values:
          jpi_classid=clsid:CAFEEFAC-0014-0002-0006-ABCDEFFEDCBA
          jpi_codebase=http://java.sun.com/products/plugin/autodl/jinstall-1_4_2-windows-i586.cab#Version=1,4,2,06
          jpi_mimetype=application/x-java-applet;jpi-version=1.4.2_06

          Since you said, you did not change anything, you're getting the expected behaviour .... If I understand correctly the documentation, maybe Peter can correct me here, also, if you read the how-to Forms JRE document, at the end of page 4 and start of page 5 (Specifying version in 1.6.0_10, use it as an example), it shows the following:
          Specifying version in 1.6.0_10
          The dynamic versioning described here does work with Internet Explorer but does
          not work with Firefox version 2 and lower. It works in version 3 of Firefox but not
          until version 1.6.0_10 of the plug-in where the version is expressed not in the
          classid (it will work for backward compatibility in IE) but in a parameter called
          java_version in either the OBJECT tag (for Internet Explorer) or in the
          EMBED tag (for Firefox)1.
          reference to either basejpi.htm or webutiljpi.htm

          <OBJECT classid="…"> …
          <PARAM NAME="JAVA_VERSION" VALUE="1.6.0">
          <EMBED SRC="" …
          java_version="1.6.0"> …
          </OBJECT>

          You should also remove the jpi-version from the jpi_mimetype:
          jpi_mimetype=application/x-java-applet
          • 2. Re: Sun JRE 1.6.0_16
            sky123
            Hi,

            I am still a little bit confused. Let me put it this way... If I do not change the default value of jpi_classid in OAS Forms 10.1.2.3 (after patchset 3 applied to 10.1.2.0.2), will users/clients who have Sun JRE 1.6.0_16 be able to run my Forms applications? There are many different versions (1.4.2_06, 1.5, 1.6) and updates already installed in client PC's and we do not want to ask our engineers to install the latest JRE again.

            I just want to make sure that, if I don't change the default jpi_classid, will it use whatever latest installed in the clients?

            Thanks.
            Andy
            • 3. Re: Sun JRE 1.6.0_16
              385818
              In pdevaal's words, as per link to thread already provided ... I think the answer is very clear there, IE and default config (exact version) will start the latest available version ... you can test run your application with different versions if you still have doubts...

              jpi_classid:
              is ignored by Mozilla-like browsers (e.g. Firefox), and is only relevant for IE.
              For IE you can specify an exact version in the classid or a version family (as shown in your example, using the FFFF). However, the latter notation only works for SUN plug-in 1.6.0.10 or higher. Specifying an exact version, however, always starts the latest available version (behaviour from version 1.5.0.9 on), so even if you specify a 1.4 version (the default config) it will start 1.6.0.x if you have installed that. With the FFFF notation you can force the latest installed version of the 1.4 or 1.5 family, as long as you also have installed a 1.6 version.
              1 person found this helpful