7 Replies Latest reply: Oct 10, 2009 8:14 AM by 97164 RSS

    Error in invoking target 'install' of makefile ...ctx/lib/ins_ctx at instal

    97164
      During link steps at installing 11gR2 on OEL5 I got:

      Exception String: Error in invoking target 'install' of makefile '/oracle/112/ctx/lib/ins_ctx.mk'. See '/oracle/oraInventory/logs/installActions2009-10-09_09-21
      -45PM.log' for details.
      Exception Severity: 1
      (no more information in logfile)
      Any idea?
      ( prerequisite checks at the beginning of install process where fine)
        • 1. Re: Error in invoking target 'install' of makefile ...ctx/lib/ins_ctx at instal
          ora_tech
          Hi,

          Please make sure that u performed all pre-requisite steps before beginning Installation.

          Refer: http://download.oracle.com/docs/cd/B28359_01/install.111/b32002/toc.htm

          Link[Similar Issue Refer|http://forums.oracle.com/forums/thread.jspa?messageID=1254866]

          Regards,
          X A H E E R
          • 2. Re: Error in invoking target 'install' of makefile ...ctx/lib/ins_ctx at instal
            97164
            The Installer checks prerequisites as successful..

            I believe (hope I step on the right way) it could be caused by:
            " 4. The gcc-4.1.2 and gcc-c++-4.1.2 RPM items above will ensure that the correct gcc / g++ versions are installed. It is also required that you ensure that these correct gcc / g++ versions are active, and in-use. Ensure that the commands "gcc version" and "g++ version" each return "4.1.x". "

            I checked it:
            [root@ozone ~]# ls -al /usr/bin | grep gcc
            lrwxrwxrwx 1 root root 3 Jan 11 2009 cc -> gcc
            -rwxr-xr-x 1 root root 914 May 22 2008 gcc
            -rwxr-xr-x 2 root root 89760 Jun 5 2007 gcc34
            -rwxr-xr-x 1 root root 2018 Jun 6 2007 gccmakedep
            -rwxr-xr-x 2 root root 196668 May 25 2008 gcc.orig
            -rwxr-xr-x 2 root root 196668 May 25 2008 i386-redhat-linux-gcc
            -rwxr-xr-x 2 root root 89760 Jun 5 2007 i386-redhat-linux-gcc34
            [root@ozone ~]# rpm -qf /usr/bin/gcc
            gcc-4.1.2-42.el5
            [root@ozone ~]# cd /tmp
            [root@ozone tmp]# gcc --version
            gcc34 (GCC) 3.4.6 20060404 (Red Hat 3.4.6-4)
            Copyright (C) 2006 Free Software Foundation, Inc.
            This is free software; see the source for copying conditions. There is NO
            warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

            Same with g++

            But how to get gcc-4.1.2 active?
            I tried to remove:
            [root@ozone tmp]# rpm -qf /usr/bin/gcc34
            compat-gcc-34-3.4.6-4
            [root@ozone tmp]# rpm -qf /usr/bin/i386-redhat-linux-gcc34
            compat-gcc-34-3.4.6-4
            [root@ozone tmp]# rpm -e compat-gcc-34-3.4.6-4
            error: Failed dependencies:
            compat-gcc-34 = 3.4.6-4 is needed by (installed) compat-gcc-34-c++-3.4.6-4.i386
            compat-gcc-34 is needed by (installed) compat-oracle-el5-1.0-5.i386

            [oracle@ozone ~]$ rpm -e compat-gcc-34-c++-3.4.6-4
            error: Failed dependencies:
            compat-gcc-34-c++ is needed by (installed) compat-oracle-el5-1.0-5.i386


            ??? What should I do with compat-oracle-el5-1.0-5.i386 ????

            I want to upgrade a 11.1.0.7 database, so there is a 11.1.0.7 Oracle on the machine (VMWare) too.
            • 3. Re: Error in invoking target 'install' of makefile ...ctx/lib/ins_ctx at instal
              97164
              but there seems some rpms missing to,

              so the prerequisite check of the 11gR2 installer is uncomplete...
              At another VM I got really a list of some missing packages.

              Hope it fixes the problem with gcc-version too.
              • 4. Re: Error in invoking target 'install' of makefile ...ctx/lib/ins_ctx at instal
                ora_tech
                Hi,

                U can donwload the rpms from Link:

                http://rpm.pbone.net/index.php3/stat/4/idpl/9866605/com/compat-gcc-34-c++-3.4.6-9.i386.rpm.html

                Regards,
                X A H E E R
                • 5. Re: Error in invoking target 'install' of makefile ...ctx/lib/ins_ctx at instal
                  97164
                  sorry, I dont need gcc3.4, 11gR2 needs gcc4.2 , but if you look above in this thread you will see that 3.4 is active.
                  I want to erase, but was not successful
                  • 6. Re: Error in invoking target 'install' of makefile ...ctx/lib/ins_ctx at instal
                    ora_tech
                    Hi,

                    The package compat-gcc-34-3.4.6-4 is used by some other rpms compat-gcc-34-c++-3.4.6-4.i386, compat-oracle-el5-1.0-5.i386. so first u have to unistall these rpms then u can Uninstall compat-gcc-34-3.4.6-4.

                    Regards,
                    X A H E E R
                    • 7. Re: Error in invoking target 'install' of makefile ...ctx/lib/ins_ctx at instal
                      97164
                      Thanks,
                      Yes, if you look above I had found this and tried to deinstall compat-gcc-34-c++-3.4.6-4 and then compat-gcc-34-c++-3.4.6-4.
                      Then I was not secure what occurs when I would uninstall compat-oracle-el5-1.0-5.i386

                      The whole stack once more:

                      (1)
                      [root@ozone tmp]# rpm -qf /usr/bin/gcc34
                      compat-gcc-34-3.4.6-4
                      [root@ozone tmp]# rpm -e compat-gcc-34-3.4.6-4
                      error: Failed dependencies:
                      compat-gcc-34 = 3.4.6-4 is needed by (installed) compat-gcc-34-c++-3.4.6-4.i386
                      compat-gcc-34 is needed by (installed) compat-oracle-el5-1.0-5.i386

                      (2)
                      [oracle@ozone ~]$ rpm -e compat-gcc-34-c++-3.4.6-4
                      error: Failed dependencies:
                      compat-gcc-34-c++ is needed by (installed) compat-oracle-el5-1.0-5.i386

                      (3)
                      [oracle@ozone ~]$ rpm -e compat-oracle-el5-1.0-5.i386
                      error: can't create transaction lock on /var/lib/rpm/__db.000

                      I will finish for today...
                      THANKS

                      Edited by: lkahlenb on Oct 10, 2009 3:13 PM