This discussion is archived
1 Reply Latest reply: Nov 3, 2009 11:24 AM by user10982990 RSS

Many tables empty after switch to new execution plan

user10982990 Newbie
Currently Being Moderated
Originally I ran the seeded Oracle R12 execution plan and the results were good. I then realized that I should be using my own execution plan. So I did the following:

1. Created a new source system container as a copy of the seeded container
2. Set the source system parameters to the same values as my previous successful run
3. Created a new execution plan
4. Added the exact same list of subject areas as the seeded execution plan
5. Generated parameters and populated values in the same way as the seeded version
6. Built the execution plan. My new execution plan has the same number of tasks as the seeded one, so all look good.
7. Choose the Reset ETL option to erase the data from the previous run using the seeded execution plan.
8. Ran my new execution plan. All tasks completed successfully. The number of completed tasks matches my run under the seeded execution plan. Also, the overall run time was about the same as the previous run. Again, all seems good.

But....following the run, many of the tables are empty (such as w_gl_balance_f, w_gl_balance_a, w_gl_other_f) while others (gl_accounts_d) are populated.

I've reviewed many of the session logs and see no obvious problems.

As a test, I tried going back to the seeded execution plan and then the data looks good. Is it possible that my switching to a new execution plan caused this problem? I don't see any differences between the plans or the resulting logs, yet one plan produces usable data and the other does not.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points