3 Replies Latest reply on Dec 1, 2009 7:59 AM by User754933-Oracle

    sendmail won't use relay

    User754933-Oracle
      A RHEL5 client set up properly to send to another host as
      a relay doesn't do it. Yes, the "DS" field is set up in sendmail.cf,
      sendmail daemon restarted a million times, etc etc.
      Everything looks fine, it just doesn't work.
      Why does it try to send the mail itself? Shouldn't even attempt
      a DNS lookup. The mailhost (relay) can do that but here, the
      client tries to do it itself for some reason. Please advise.
      I try sending a test
      to see if this is working and here's what I get:

      [root@e1198pdb3 ~]# sendmail -v -d8.99 -d38.99 the...@gmail.com
      openmap() dequote:dequote NULL: valid
      openmap() host:host NULL: valid
      getcanonname(gmail.com), trying dns
      dns_getcanonname(gmail.com, trymx=1)
      dns_getcanonname: trying gmail.com. (AAAA)
      NO: errno=111, h_errno=2
      dns_getcanonname: trying gmail.com. (A)
      NO: errno=111, h_errno=2
      dns_getcanonname: trying gmail.com. (MX)
      NO: errno=111, h_errno=2
      dns_getcanonname: trying gmail.com. (AAAA)
      NO: errno=111, h_errno=2
      dns_getcanonname: trying gmail.com. (A)
      NO: errno=111, h_errno=2
      dns_getcanonname: trying gmail.com. (MX)
      NO: errno=111, h_errno=2
      getcanonname(gmail.com), trying files
      text_getcanonname(gmail.com)
      getcanonname(gmail.com), failed, status=68
      gmail.com: Name server timeout
      derf...@gmail.com... Transient parse error -- message queued for
      future delivery
      closemaps: closing host (NULL)
      closemaps: closing dequote (NULL)
        • 1. Re: sendmail won't use relay
          653835
          Hi user754933

          Try to make sure first of all the the dns is working with the given address gmail.com

          to check that use nslookup gmail.com

          check also the content of /etc/nsswitch.conf file

          let us know the results.

          thanks
          • 2. Re: sendmail won't use relay
            User754933-Oracle
            DNS on the host is fine.
            nslookup worked on any address.
            nsswitch.conf looks to files,dns for hosts.
            Nothing wrong there either.
            • 3. Re: sendmail won't use relay
              User754933-Oracle
              Further sweetening the pot, the relay has in its log (after I turned logging up to level 15), the following.
              Which still begs the question WHY the dbserver is not issuing the "MAIL" command to initiate transfer??!!

              It just does a "QUIT" (none of my other servers do this!). What's wrong?
              Thanks in advance for helping.
              Dec  1 02:36:44 mailhost sendmail[21027]: NOQUEUE: connect from dbserver [10.156.90.13]
              Dec  1 02:36:44 mailhost sendmail[21027]: AUTH: available mech=PLAIN LOGIN ANONYMOUS, allowed mech=EXTERNAL GSSAPI KERBEROS_V4 DIGEST-MD5 CRAM-MD5
              Dec  1 02:36:44 mailhost sendmail[21027]: nB17ai5G021027: Milter: no active filter
              Dec  1 02:36:44 mailhost sendmail[21027]: nB17ai5G021027: --- 220 localhost.localdomain ESMTP Sendmail 8.13.8/8.13.0; Tue, 1 Dec 2009 02:36:44 -0500
              Dec  1 02:36:44 mailhost sendmail[21027]: nB17ai5G021027: <-- EHLO localhost.localdomain
              Dec  1 02:36:44 mailhost sendmail[21027]: nB17ai5G021027: --- 250-localhost.localdomain Hello dbserver [10.156.90.13], pleased to meet you
              Dec  1 02:36:44 mailhost sendmail[21027]: nB17ai5G021027: --- 250-ENHANCEDSTATUSCODES
              Dec  1 02:36:44 mailhost sendmail[21027]: nB17ai5G021027: --- 250-PIPELINING
              Dec  1 02:36:44 mailhost sendmail[21027]: nB17ai5G021027: --- 250-8BITMIME
              Dec  1 02:36:44 mailhost sendmail[21027]: nB17ai5G021027: --- 250-SIZE
              Dec  1 02:36:44 mailhost sendmail[21027]: nB17ai5G021027: --- 250-DSN
              Dec  1 02:36:44 mailhost sendmail[21027]: nB17ai5G021027: --- 250-ETRN
              Dec  1 02:36:44 mailhost sendmail[21027]: nB17ai5G021027: --- 250-DELIVERBY
              Dec  1 02:36:44 mailhost sendmail[21027]: nB17ai5G021027: --- 250 HELP
              Dec  1 02:36:44 mailhost sendmail[21027]: nB17ai5G021027: <-- QUIT
              Dec  1 02:36:44 mailhost sendmail[21027]: nB17ai5G021027: --- 221 2.0.0 localhost.localdomain closing connection
              Dec  1 02:36:44 mailhost sendmail[21027]: nB17ai5G021027: dbserver [10.156.90.13] did not issue MAIL/EXPN/VRFY/ETRN during connection to MTA
              MEANWHILE:... on the internal dbserver ('localhost' as it's referred to here, and don't worry that the times are
              a little out of sync):
              Dec  1 02:38:18 localhost sendmail[24169]: nB17cImU024169: from=root, size=47, class=0, nrcpts=1, msgid=<200912010738.nB17cImU024169@localhost.localdomain>, relay=root@localhost
              Dec  1 02:38:18 localhost sendmail[24170]: NOQUEUE: connect from localhost.localdomain [127.0.0.1]
              Dec  1 02:38:18 localhost sendmail[24170]: AUTH: available mech=PLAIN LOGIN ANONYMOUS, allowed mech=EXTERNAL GSSAPI KERBEROS_V4 DIGEST-MD5 CRAM-MD5
              Dec  1 02:38:18 localhost sendmail[24170]: nB17cIit024170: Milter: no active filter
              Dec  1 02:38:18 localhost sendmail[24170]: nB17cIit024170: --- 220 localhost.localdomain ESMTP Sendmail 8.13.8/8.13.8; Tue, 1 Dec 2009 02:38:18 -0500
              Dec  1 02:38:18 localhost sendmail[24170]: nB17cIit024170: <-- EHLO localhost.localdomain
              Dec  1 02:38:18 localhost sendmail[24170]: nB17cIit024170: --- 250-localhost.localdomain Hello localhost.localdomain [127.0.0.1], pleased to meet you
              Dec  1 02:38:18 localhost sendmail[24170]: nB17cIit024170: --- 250-ENHANCEDSTATUSCODES
              Dec  1 02:38:18 localhost sendmail[24170]: nB17cIit024170: --- 250-PIPELINING
              Dec  1 02:38:18 localhost sendmail[24170]: nB17cIit024170: --- 250-8BITMIME
              Dec  1 02:38:18 localhost sendmail[24170]: nB17cIit024170: --- 250-SIZE
              Dec  1 02:38:18 localhost sendmail[24170]: nB17cIit024170: --- 250-DSN
              Dec  1 02:38:18 localhost sendmail[24170]: nB17cIit024170: --- 250-ETRN
              Dec  1 02:38:18 localhost sendmail[24170]: nB17cIit024170: --- 250-DELIVERBY
              Dec  1 02:38:18 localhost sendmail[24170]: nB17cIit024170: --- 250 HELP
              Dec  1 02:38:18 localhost sendmail[24170]: nB17cIit024170: <-- MAIL From:<root@localhost.localdomain> SIZE=47
              Dec  1 02:38:18 localhost sendmail[24170]: nB17cIit024170: --- 250 2.1.0 <root@localhost.localdomain>... Sender ok
              Dec  1 02:38:18 localhost sendmail[24170]: nB17cIit024170: <-- RCPT To:<derf109@gmail.com>
              Dec  1 02:38:18 localhost sendmail[24170]: nB17cIit024170: --- 250 2.1.5 <derf109@gmail.com>... Recipient ok
              Dec  1 02:38:18 localhost sendmail[24170]: nB17cIit024170: <-- DATA
              Dec  1 02:38:18 localhost sendmail[24170]: nB17cIit024170: --- 354 Enter mail, end with "." on a line by itself
              Dec  1 02:38:18 localhost sendmail[24170]: nB17cIit024170: from=<root@localhost.localdomain>, size=346, class=0, nrcpts=1, msgid=<200912010738.nB17cImU024169@localhost.localdomain>, proto=ESMTP, daemon=MTA, relay=localhost.localdomain [127.0.0.1]
              Dec  1 02:38:18 localhost sendmail[24170]: nB17cIit024170: --- 250 2.0.0 nB17cIit024170 Message accepted for delivery
              Dec  1 02:38:18 localhost sendmail[24169]: nB17cImU024169: to=derf109@gmail.com, ctladdr=root (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30047, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (nB17cIit024170 Message accepted for delivery)
              Dec  1 02:38:18 localhost sendmail[24172]: nB17cIit024170: SMTP outgoing connect on dbserver
              Dec  1 02:38:18 localhost sendmail[24170]: nB17cIiu024170: <-- QUIT
              Dec  1 02:38:18 localhost sendmail[24170]: nB17cIiu024170: --- 221 2.0.0 localhost.localdomain closing connection
              Dec  1 02:38:23 localhost sendmail[24172]: nB17cIit024170: SYSERR(root): mailhost config error: mail loops back to me (MX problem?)
              Dec  1 02:38:23 localhost sendmail[24172]: nB17cIit024170: to=<derf109@gmail.com>, ctladdr=<root@localhost.localdomain> (0/0), delay=00:00:05, xdelay=00:00:05, mailer=relay, pri=120346, relay=mailhost [10.156.80.131], dsn=5.3.5, stat=Local configuration error
              Dec  1 02:38:23 localhost sendmail[24172]: nB17cIit024170: alias postmaster => root
              Dec  1 02:38:23 localhost sendmail[24172]: nB17cIit024170: nB17cNit024172: DSN: Local configuration error
              Dec  1 02:38:23 localhost sendmail[24172]: nB17cNit024172: to=<root@localhost.localdomain>, delay=00:00:00, xdelay=00:00:00, mailer=local, pri=31601, dsn=2.0.0, stat=Sent
              Dec  1 02:38:23 localhost sendmail[24172]: nB17cNit024172: done; delay=00:00:00, ntries=1
              Dec  1 02:38:23 localhost sendmail[24172]: nB17cIit024170: done; delay=00:00:05, ntries=1
              Any ideas?