1 Reply Latest reply on Aug 30, 2012 8:21 AM by 912266

    SDO invocation errors after re-deploying composites


      We have an application with EJB exposing SDO web services and composites calling those services.
      The wsdl and xsd files for those services are pushed in MDS by our build.

      The problem is every time we re-deploy the application (EJBs, wsdl/xsd to MDS, then composites), the composite throw errors when trying to invoke the SDO web services. For instance:

      Caused by: java.lang.IllegalArgumentException: Exception [EclipseLink-45010] (Eclipse Persistence Services - 1.1.1.v20090430-r4097): org.eclipse.persistence.
      Exception Description: Type not found for interface [com.ed.ted.sdo.EscSDO]
      at org.eclipse.persistence.sdo.helper.delegates.SDODataFactoryDelegate.create(SDODataFactoryDelegate.java:54)

      The problem also happens when we re-deploy one of the composite making SDO calls.
      We use ant scripts to build and deploy.

      The only solution we have found so far to get rid of this issue is to follow these steps:
      - un-deploy all ejbs and composite
      - stop the server
      - delete domain/servers/cache and tmp
      - restart server
      - re-deploy ejbs and composites

      Has anyone encountered this kind of issues ?

      We can't figure out if it is linked with MDS caches, SDO or weblogic.

      Thanks for your help
        • 1. Re: SDO invocation errors after re-deploying composites
          Thanks a lot Sebastien,

          I had the exact same error when trying to invoke an EJB/JPA based SDO exposed as a SOAP WebService (based on Biemond's example: http://biemond.blogspot.be/2012/08/generating-ejb-sdo-service-interface.html).

          To get rid of this strange error, I had to:

          1) delete domain/servers/cache (not the tmp)
          2) restart server

          Then when I invoked the SDO service from SoapUI again, it worked! :)

          Thanks again,