5 Replies Latest reply: Dec 4, 2009 8:30 AM by Alex RSS

    Data migration issue from 8.5 to 9.0


      I need to upgrade my otm application with the latest version 9.0. besides this, I would also need to migrate my data from 8.5 to 9.0. For that I have already created
      new database ,
      made an entry in the tns.ora file

      While logged into the application, it was showing my new db name in the list but I was not able to logged in my pre-defined user details. It was showing a message that "*the oracle test manager for web applications database you are connecting to is an old version and must be updated. would you like to update now* ?" and when I clicked as ‘Yes’ then it showed " *The oracle test manager for web applications database could not be updated. please make sure that the user had administrator rights for the database and the password entered is correct*."

      As far as I know that there might be some changes in the db schema that’s why i was not able to logegd in
        • 1. Re: Data migration issue from 8.5 to 9.0

          All you need to do is login to the admin app using a user that has administration credentials.


          • 2. Re: Data migration issue from 8.5 to 9.0
            Hello Alex,

            I've tried with the administrator login in the admin app with the new database name which i had created in the database configuration. unfortunately it was also shown the same issue

            Edited by: user10707577 on Dec 3, 2009 12:32 AM
            • 3. Re: Data migration issue from 8.5 to 9.0

              The error message that you are getting is due to using a user that does not have administrator rights (that's OTM admin right not DB admin rights) or entering the wrong password.

              Unfortunately there is no way to reset a password, you can run the following SQL againts the OTM db to get a list of admin users:

              select * from "OTM"."Users" where ISADMIN = 1 and deleted = 0;

              Note that you may need to change OTM for the user that owns the OTM tablespace, default is OTM.

              If you know the password for one of them try using that username/password combination other ways you are gonna have to look for a user that you know the password, to do so run the following query:

              select * from "OTM"."Users" where ISADMIN = 0 and deleted = 0;

              That will give you a list of none admin users, then find a user that you know the password off and update the ISADMIN to equal 1 you can use the following SQL query:

              update "OTM"."Users" set isadmin = 1 where userid = +<the_user_id>+;

              Change the <the_user_id> for the actual user_id.

              Then you should be able to login using that user.

              Hope this helps

              • 4. Re: Data migration issue from 8.5 to 9.0
                Thnx alex, it was successfully done!!

                but found 1 strange issue:

                *1st time*
                we've run the query as per your instructions. while working on that, we found that "Administrator" user had already that OTM admin rights but it was not working, don't 9 the reason . besides that, there was one another "Default" user mentioned in the list. we'd set the rights for that and logged into the admin app. there it worked and also asked for the upgrade version. we also verified that all earlier data is now available.

                but issues comes when i logged in *2nd time* in the admin app, there i was not able to connect with both the users "Administrator" & "Default" users

                Fortunately, while setting the OTM admin rights, i applied on 1 another user name also and currently only that user is working. could you tell me the reason of that why i am not able to connect with that users?
                • 5. Re: Data migration issue from 8.5 to 9.0

                  can you reset the passwords for the admin and default users, I'm sure is just a password issue.