You're almost there! Please answer a few more questions for access to the Applications content. Complete registration
Interested in joining? Complete your registration by providing Areas of Interest here. Register

Calculate tax API returns 403 error on Integration but works on Postman

Received Response
11
Views
2
Comments

Summary: Hey folks!

I have been having a situation with the Calculate tax and derive account API (https://docs.oracle.com/en/cloud/saas/procurement/23b/fapra/op-purchaserequisitions-purchaserequisitionsuniqid-action-calculatetaxandaccounting-post.html). Any call from Postman works perfectly fine and the Purchase Requisition is submitted. However, when using the REST adapter in an integration, with a connection that uses the exact same user, and the exact same headers in place, I get a 403 - Forbidden error in return. Is it possible that this is some sort of configuration on the Integration instance?

The API only appears to be when being sent an empty object on the request's body. Thus, I have tried doing so using a binary content type, JSON with 'enforce empty object' configured, as the documentation suggests, and the result is always the same. I did not forget to change the content-type header to "application/vnd.oracle.adf.action+json''. Also, I tried doing so on the invoke action configuration itself as well as on the Mapper, when configuring a default HTTP header.

Howdy, Stranger!

Log In

To view full details, sign in.

Register

Don't have an account? Click here to get started!