HI everyone.
I have a problem when I try to update my rows from my Admin Tool.
The error says that there is a error executing SQL instruction and ORA-00942 the table or view does not exist.
Has anyone experienced these problems ? Please help.
Hi,
Your problem is, most likely, one of two things: either the object you're trying to access doesn't exist or the user you're trying to access that object with doesn't have the correct permissions to query that object.
Go to your connection pool object and get the username defined there. Login into your database (using sql developer for example) with that username and issue a simple query such as "SELECT * FROM YOUR_OBJECT". You should get the same error that you get in the RPD (table or view does not exist).
So what you need to do will be one of the following options:
1 - Object doesn't exist at all in the database - you need to create it
2 - Object exists - you either grant the correct permissions for the user that you're using in your connection pool to query that object or you need to change the user querying that object in the connection pool.
Does the user in the connection pool has the privilege to access this table in the database?
You're in offline mode. Does the machine running the Admin Tool actually HAVE the ability to connect to those sources with the right / sufficient credentials?
Yes, you're right, I am in offline mode. About the credentials of the machine, I put down the source's firewalls. Which other credentials does the machine, where Admin Tool is running, need?
Hi Pedro F. thank you so much for your help.
I checked again if the user of my connection pool has right privileges and if objects exists, but everythin is ok. The user has granted the correct permissions and the objetcs does exists.
Even, I tried to connect as system and I got the same error.
May be the problem is that my machine running the Admin tool doesn't have the right / sufficient credentials to connect to my source.
Thank you for your help Mr. Christian Berg, if you know what credentials need my machine please let me know.
The table giving you the error is owned by the user you used to connect? (so into the schema use used in your connection pool)
If not you must check the checkbox to use fully qualified names if it isn't checked in the connection pool.
Here is a few things you can do.
1. Perform a tnsping to the database from the machine from which you are opening the admintool.
2. Connect using sqlplus/sql developer with the same user as in the connection pool and query the tables in question.
3. You could also try importing a table from the database just to see if admintool is able to communicate to the database.
4. Also you can perform a telnet from command prompt to the database to rule out firewall issues.
Also a question, is the user in the connection pool the owner of the tables?
Gianni Ceresa, thank you for your help.
The user that I am using is not the owner, but it has the right privileges.
Sherry George thank you for your help.
1. Perform a tnsping to the database from the machine from which you are opening the admintool. R.- I performed a tnsping to the database succesfully.
2. Connect using sqlplus/sql developer with the same user as in the connection pool and query the tables in question. R.- I validated the user in DB source as in the connection pool.
3. You could also try importing a table from the database just to see if admintool is able to communicate to the database. R.- admin tool can import the tables, it is able to communicate to the database.
4. Also you can perform a telnet from command prompt to the database to rule out firewall issues. R.- I will try a telnet to the database, I will let you know the results.
Also a question, is the user in the connection pool the owner of the tables? R.- The user is not the owner, but it has the right privileges.
THANK YOU FOR YOUR HELP!!
Description: Join our Product Management team to learn about new features that are part of 26.R3 Application release of Fusion Data Intelligence (SCM). The session will cover updates on Supply Chain Management and Procurement. Presented by: Anil Sebastian - Senior Director, SCM Product Management, Fusion Data Intelligence…
Good day, please kindly assist. We are creating a graph to calculate the number of assets per milestones. However, the planners have only populated assets for only one milestone from the list of milestones the customer wants to track. Which gives an incorrect view as the project moves past different milestones that it has…
I scheduled the report in OTBI and the agent was run successfully. However, I do not receive the report after the run in my inbox. The addresses are properly recorded, and the report is in an excel format and saved as a pivot table in otbi. What can be the cause?
Anyone has any idea why the OAC documentation on custom viz is not available now? I was able to access till last week - https://docs.oracle.com/en/cloud/paas/analytics-cloud/acsdv/build-package-extension.html. Does this mean OAC doesnt support custom viz or custom workbook extensions?
I made a parameter with letter range values… put it into a dashboard filter. Then I created an expression filter to bind it to my last name column in the table with the image I uploaded here. I am getting the following error??? Invalid Expression. Validation of parameter values failed. A general error has occurred. Message…
Does Oracle Analytics Server 2026 include AI features such as a built-in chatbot or AI Assistant? If not, are there any plans or indications that these AI capabilities will be introduced in a future OAS release?