HI everyone.
I have a problem when I try to update my rows from my Admin Tool.
The error says that there is a error executing SQL instruction and ORA-00942 the table or view does not exist.
Has anyone experienced these problems ? Please help.
If the user is not the owner, then as Gianni mentioned, have you checked the fully qualified table name in connection pool setting? Or if not, are you using public synonyms?
I never talked about privileges, but fully qualified name which is: schema.tablename vs tablename (without the schema).
An option in the connection pool which by default isn't checked (it's a checkbox) and you must enable to make it works.
That's a simple SQL thing: you can't expect the database scans all the schemas you have some privileges to find out if by mistake there is an object with a matching name, also because ... what happen if same name in 2 schemas?
That's why there is that checkbox which, IMHO, must always be enabled because it doesn't cost anything but prevent so many issues ....
Gianni Ceresa
Thank you for your help again.
I already checked the checkbox "checkbox to use fully qualified names" and I still have the same error, BUT as I said befeore, the user that I am using is not the owner of the table so, if I connect to source through sqlplus with this user I have to use schema.table_name to be able to see the data, so I created a synonym for a table to validate if it works and it does. BUT I think that it is not the best solution. Do I have to create synosyms for every table when I use another user who is not owner of table??
Hi,
Can you try giving the "SELECT" privilege to user used in connection pool ?
GRANT SELECT ON owner.table TO user;
3057520 wrote:so I created a synonym for a table to validate if it works and it does. BUT I think that it is not the best solution. Do I have to create synosyms for every table when I use another user who is not owner of table??
Why did you create a synonym?
It's useless, when checking the "fully qualified name" checkbox OBIEE uses the schema.table_name syntax in all the queries, so not a problem if your connection pool uses a different user, it will just works.
Get rid of the synonym, do not start having weird things like that in your database or you will end up with a messy DB you will not manage to keep clean and with errors because using the wrong object at some point.
Just to know: what is your DB? Oracle but which version?
Silly question, did you confirm that the db you are connecting to, using sqlplus and the one in the admin tool connection pool are the same?
Thank you Gianni Ceresa.
I created a new RPD and checked the "fully qualified name" checkbox and finally it works perfectly without synonyms.
FYI, my db source is Oracle 11g (11.2.0.4).
THANK YOU!! USEFUL SUPPORT.
Best regards,
Description: Join our Product Management team to learn about new features that are part of 26.R3 Application release of Fusion Data Intelligence (SCM). The session will cover updates on Supply Chain Management and Procurement. Presented by: Anil Sebastian - Senior Director, SCM Product Management, Fusion Data Intelligence…
Good day, please kindly assist. We are creating a graph to calculate the number of assets per milestones. However, the planners have only populated assets for only one milestone from the list of milestones the customer wants to track. Which gives an incorrect view as the project moves past different milestones that it has…
I scheduled the report in OTBI and the agent was run successfully. However, I do not receive the report after the run in my inbox. The addresses are properly recorded, and the report is in an excel format and saved as a pivot table in otbi. What can be the cause?
Anyone has any idea why the OAC documentation on custom viz is not available now? I was able to access till last week - https://docs.oracle.com/en/cloud/paas/analytics-cloud/acsdv/build-package-extension.html. Does this mean OAC doesnt support custom viz or custom workbook extensions?
I made a parameter with letter range values… put it into a dashboard filter. Then I created an expression filter to bind it to my last name column in the table with the image I uploaded here. I am getting the following error??? Invalid Expression. Validation of parameter values failed. A general error has occurred. Message…
Does Oracle Analytics Server 2026 include AI features such as a built-in chatbot or AI Assistant? If not, are there any plans or indications that these AI capabilities will be introduced in a future OAS release?