5 Replies Latest reply on Jan 2, 2008 10:31 PM by alwu-Oracle

    Problem after Jena Patch

    560844
      I have just applied the Jena patch for 11g and I am now having trouble with the BatchLoader. The output from my batch command is:

      Note: You can use JVM properties -Ddb.user=<user> -Ddb.password=<password> -Ddb.host=<host> -Ddb.sid=<sid> -Ddb.port=<port> to configure database connection.
      JVM property -Dappend=true can be used to specify APPEND mode. By default, this option is false.
      JVM property -Dexchange=true can be used to allow table partition exchange which is faster and less space consuming.
      This option is less robust though. By default, it is false

      Connecting to jdbc:oracle:thin:@dev1.company.com:1521:MUM as user demo
      Append mode
      Copy existing data out
      Just load triples into one column
      Temporary table already exists!
      java.sql.SQLException: ORA-00955: name is already used by an existing object
      ORA-06512: at "MDSYS.SDO_RDF_INTERNAL", line 3449
      ORA-06512: at "MDSYS.SDO_RDF_INTERNAL", line 3485
      ORA-06512: at "MDSYS.RDF_APIS", line 910
      ORA-06512: at line 1

      at oracle.jdbc.driver.SQLStateMapping.newSQLException(SQLStateMapping.java:74)
      at oracle.jdbc.driver.DatabaseError.newSQLException(DatabaseError.java:110)
      at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:171)
      at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:455)
      at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:413)
      at oracle.jdbc.driver.T4C8Oall.receive(T4C8Oall.java:1030)
      at oracle.jdbc.driver.T4CCallableStatement.doOall8(T4CCallableStatement.java:191)
      at oracle.jdbc.driver.T4CCallableStatement.executeForRows(T4CCallableStatement.java:944)
      at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:1222)
      at oracle.jdbc.driver.OraclePreparedStatement.executeInternal(OraclePreparedStatement.java:3381)
      at oracle.jdbc.driver.OraclePreparedStatement.execute(OraclePreparedStatement.java:3482)
      at oracle.jdbc.driver.OracleCallableStatement.execute(OracleCallableStatement.java:3839)
      at oracle.jdbc.driver.OraclePreparedStatementWrapper.execute(OraclePreparedStatementWrapper.java:1085)
      at oracle.spatial.rdf.client.NTripleConverter.loadNTriple(NTripleConverter.java:391)
      at oracle.spatial.rdf.client.BatchLoader.main(BatchLoader.java:302)

      I have tried dropping and re-creating all sorts of things, but I've stopped shy of dropping and re-creating the MDSYS user. Any thoughts on the cause of this problem?

      Message was edited by:
      StinkyMatt
        • 1. Re: Problem after Jena Patch
          610533
          Hi Matt

          It looks like you are getting the same error I am with the batch loader, see message a few before yours. It also hasn't got an replies.
          I've not done anything except installed the current download of 11g for windows.

          Where did you get the patches from ?

          Cheers

          Phil
          • 2. Re: Problem after Jena Patch
            560844
            I downloaded the patch from the Oracle Semantic technologies homepage. Google: "Oracle semantic"
            • 3. Re: Problem after Jena Patch
              Mannamal-Oracle
              First more details on the location of the 11g patch:

              The patch is available on the Oracle Semantic Technologies page, it is just not labeled accurately (we are fixing that). Please go to http://www.oracle.com/technology/tech/semantic_technologies/index.html, click on 'software' in the right column, and then click on 'Download the Patch for Oracle Database 11gR1'. This patch is listed under the Oracle Jena Adaptor, and is also the general patch that can be used for 11g, including for using 11g with TopBraid Composer.

              I apologize for the delayed reply.

              Second, you could try the following, and the re-try the batch load:

              connect as mdsys
              exec sdo_rdf.cleanup_batch_load(<name_of_table_containing_triple_column>)

              If you are using Oracle11g, may I ask why you are not using the bulk loader? That will be faster. (see section 1.7 in the Oracle 11g Semantic Technologies documentation).

              Melli
              • 4. Re: Problem after Jena Patch
                alwu-Oracle
                Does the Batch Loader problem still exist (after applying Melli's suggestion)?

                Thanks,

                Zhe (Alan)
                • 5. Re: Problem after Jena Patch
                  alwu-Oracle
                  Could you login using sqlplus as MDSYS,

                  and then do

                  select * from tab where tname like 'RDF_LINK$_%';