Register today for Oracle CloudWorld. October 17th - 20th, Las Vegas

Register now

Hillel Cooperman, Senior VP of User Experience Design, has a message for you on Oracle CloudWorld

Watch now
Using comma in search parameters for suppliername — Cloud Customer Connect
You're almost there! Please answer a few more questions for access to the Applications content. Complete registration
Interested in joining? Complete your registration by providing Areas of Interest here. Register

Using comma in search parameters for suppliername

Received Response
15
Views
3
Comments
edited Feb 17, 2020 9:58PM in Supplier Management 3 comments

Content

How do you escape a comma in a query in a REST call?  For instance, in q : Supplier=Jones, White and Hunt  the comma causes issue?

I've tried Supplier="Jones, White and Hunt" and Supplier="Jones\, White and Hunt" and Supplier="Jones%, White and Hunt" and Supplier="Jones?, White and Hunt"

Also tried Supplier="Jones%2c White and Hunt" and Supplier="Jones%2c, White and Hunt" don't work. (Also tried with Capital C, but no result either)

As well as Supplier="Jones, White and Hunt" 

No luck on any of them.

code being used (python) is:
headers = {'Content-Type' : 'application/vnd.oracle.adf.resourcecollection+json',}

Howdy, Stranger!

Log In

To view full details, sign in.

Register

Don't have an account? Click here to get started!