You're almost there! Please answer a few more questions for access to the Applications content. Complete registration
Interested in joining? Complete your registration by providing Areas of Interest here. Register

Invalid XML Characters due to Data masking in Coupa

Accepted answer
5
Views
3
Comments
edited Jan 15, 2021 2:32AM in Integration 3 comments

Summary

The DOM Parsing is failing due to existence of some special characters.

Content

Dear Experts,

I need some suggestions on this one we are facing from quite a long time.

This happens in non prod ICS environment when the end system's supplier data  gets cloned to their non prod system and then masked. 

We are using this API from End System :- 

https://success.coupa.com/Integrate/Technical_Documentation/API/Resources/Transactional/purchase_orders/PO_Change

So when we try processing these replys' we receive such errors.

Exception :- 

[2021-01-13T13:46:19.739+00:00] [ics_server1] [ERROR] [OSB-381750] [oracle.osb.transports.sb.sbtransport] [tid: [ACTIVE].ExecuteThread: '42' for queue: 'weblogic.kernel.Default (self-tuning)'] [userId: XXXXXXXX] [ecid: 005iCXPAfRJ4yk4_rTT4iY0000ly0010fu,1:160075:17:1] [APP: Service Bus JCA Transport Provider] [oracle.soa.tracking.FlowId: 15630880] [oracle.soa.tracking.InstanceId: 46995672] [oracle.soa.tracking.SCAEntityId: 210339] [FlowId: 0000NRvz^d75IfgLpE5EiY1U1gHA003jYJ] Unexpected error happened in the SB Transport at SBInboundMessageContext.close due to com.bea.wli.sb.sources.TransformException: Failed transforming to a DOMResult[[

Tagged:

Howdy, Stranger!

Log In

To view full details, sign in.

Register

Don't have an account? Click here to get started!