You're almost there! Please answer a few more questions for access to the Applications content. Complete registration
Interested in joining? Complete your registration by providing Areas of Interest here. Register

Unable to Repair XFS Filesystem Using XFS Repair

Closed
1
Views
0
Comments
edited Jun 30, 2022 1:51PM in Linux

To fix this error, run these commands:

1) Attempt to mount the partition to replay the log. Back up any important data on the partition if the attempted mount is possible.

# mount -t xfs /dev/<DEVICE> /<MOUNT>

2) If the partition was successfully mounted, unmount the filesystem, and then re-run the "xfs_repair -v" command.

# unmount /dev/<DEVICE>

# xfs_repair -v /dev/<DEVICE>

3) If the partition was not able to be successfully mounted, or if you still get the same error message when running "xfs_repair -v", try running xfs_repair with the "-L Force Log Zeroing" flag as a last resort. This option forces xfs_repair to zero the log even if it is dirty (contains metadata changes). Zeroing the log can leave the file system in an inconsistent state, resulting in data loss and data corruption, however it may allow uncorrupted data to be recovered.

Howdy, Stranger!

Log In

To view full details, sign in.

Register

Don't have an account? Click here to get started!