You're almost there! Please answer a few more questions for access to the Applications content. Complete registration
Interested in joining? Complete your registration by providing Areas of Interest here. Register

AutoREST POST End-point loses all data

Accepted answer
31
Views
11
Comments
edited Jan 4, 2024 11:05AM in Autonomous Database 11 comments

Summary:

When using AutoREST on 23C for a specific table, if I POST to it, it loses all data that is sent along with it. This is only for this specific table, but another table works just fine. I've tried disabling and reenabling the AutoREST functionality, no luck. I even tried creating a new database instance and loading the same schema, and still had the same error.

If I add directly to the database through SQL Developer, it works.

Any tips on this or where to find logs to troubleshoot?


The only trigger is the ID column, which sequentially increments. I had a constraint besides not null on the ID, and originally the request was failing because of the constraint (The request was rejected because it violates a data integrity constraint: ORA-01400: cannot insert NULL into (\"CEPHISSO\".\"NOTES\".\"PLATFORM_ACCOUNTS_PLATFORM_ACCOUNT_ID\")\nORA-06512: at line 4\n). Once I disabled this constraint, the issue went away and I discovered that all the values in the POST request were just being silently discarded.

Howdy, Stranger!

Log In

To view full details, sign in.

Register

Don't have an account? Click here to get started!