When navigating SuiteCommerce websites, users may encounter errors such as 'Internal Error' or 'There has been an internal error'.
One potential cause of this error could be a failed Search Index Update or Search Index Rebuild process that occurs when an active Web Store item record is updated. In such cases, NetSuite initiates a search index update job and queues it in the Index job queue to ensure proper indexing of item records on the search server.
A Search Index Rebuild operation is required when any of the following modifications are made to the NetSuite account:
- Changing the Facets, Search, and Sort fields (using the Search Index subtab of the Web Site Setup page).
- Adding or removing languages.
- Adding or removing subsidiary accounts.
- Changing website currencies when the site has currency-based fields configured as facets or sort options (for example, price or cost).
- Changing the preference for including out-of-stock items in the Web Store (on the Web Site Setup Page).
- Deleting a SuiteCommerce Advanced Web Site, which deletes the index for the site.
When search index rebuilds or update jobs fail, the user may encounter an 'Internal Error' while exploring the web shop for any changes made. One possible remedy is to submit a fresh index update or rebuild job. In most cases, this issue can be resolved by rebuilding the search index. You can visit New to NetSuite | SuiteCommerce Advanced Search Index for more information on how to check and rebuild the search index.
Note: A maximum of two index rebuild jobs are permitted within 24 hours.
Stay tuned for upcoming articles where we will explore different errors encountered in SuiteCommerce Bundles under the SuiteCommerce Advanced product area. Follow the Follow New to NetSuite > SuiteCommerce, Mobile, and Retail to be notified whenever a new article is posted.