Oracle Transactional Business Intelligence

Products Banner

BIP layout using space as a number grouping separator

Received Response
36
Views
1
Comments

Summary

We have a request from the business users at our Hungarian branch to show longer salaries as '123 456' in our Compensation Statement (from the Comp Workbench not Total Comp).

Content

We have a request from the business users at our Hungarian branch to show longer salaries as '123 456' in our Compensation Statement (from the Comp Workbench not Total Comp). This is using a space as the grouping separator and no decimal points.

I know that the grouping separator is supposed to use locale at run-time. So I've tried the format of <?format-number:BASE_SALARY_NEW;'999G999G999'?>. However, when we upload this in the Comp Plan, the locale appears to default to English and we end up seeing commas as the separators. I've also tried changing the locale AND default locale in BI Publisher on the template from the report (/shared/Human Capital Management/Compensation/Workforce Compensation/Compensation Workbench Print Statements). It seems that the grouping separator for Hungary's locale should be a space (http://www.localeplanet.com/java/hu-HU/). But the separator still appears as a comma for me.

I've tried to force the format mask by using <?format-number:BASE_SALARY_NEW;'999 999 999'?> but this does not work and the extra spaces come after the numbers.

My questions
Is there a way to make the grouping separator be spaces?
Is there a better/different way to set locale than what I'm doing?

Thanks!

hu_locale.PNG

Answers

  • In preferences (general preferences for all of Fusion Apps) under the regional preferences you can set the number format.  There is a format with a space as the thousands separator.  Would this work?

    Regards

    Tim