Oracle Transactional Business Intelligence

Products Banner

CSV Export with limited range of measures/columns

Received Response
115
Views
11
Comments

Content

I have created an analysis on employees that works very well for HR reporting.

Due to the fact that I combine multiple subject areas I have entered several measures as well that are not necessary for the final (exported) output. I usually exclude the columns I don't need in the view edit and it works perfect for xls, pdf, exports.


​Whenever I run a CSV- export with the same data however I get the whole set of infomation exported, including all columns that I had excluded. How can I reduce my CSV-export to the same amount of information as it is in the other exports?

I guess it is a really easy step, but I couldn't find the right trigger so far.

 

Thanks for all information in advance.

 

BR

Stefan

Answers

  • Prudence K
    Prudence K ✭✭✭✭

    Hi Stefan - it's my understanding that you can hide columns in two places.

    Results tab/View Layout: Hidden here hides from Excel
    Criteria tab/Column Properties/Column Format tab: Hidden here hides from CSV AND from the Results tab View

    I hope that helps!

  • Hi prudence, thanks for your help, but that does not help in my case where I have to combine multiple subject areas and therefore have to select measures from each area that are not necessary for the final output).

     

    However Mr. Christian Berg pointed out by mail that CSV is a raw export in every case, so there is no possibility to achive my task. via cas-export. I have to find another solution.

     

    Thank you all for your help. 

  • Prudence K
    Prudence K ✭✭✭✭

    Stefan - not sure I understand ... if you hide the measures on the Criteria tab, it will still run, it's just hidden from view.  I have tested this and it is working for me (hidden field not showing on CSV output), so unsure if I am misunderstanding what you are trying to do?

  • Hi Prudence - and thanks for not giving up on me ;-)

    I actualy don't know what you mean by saying "hide measures on Criteria tab". As far as I understood it the hide option is available on the Results page > Compound Layout part only.

     

    BR

    Stefan

    Criteria_Tab_OTBI.PNG

  • Column properies -> Hide the column there

    (yay posting works now)

  • O...., if it is true what I suspect then the joke is on me :-(

    I guess you are talking about the COLUMN FORMAT TAB under column properties (for it is the only place with a HIDE checkbox). I knew this field, but I always thought it is referring to coulmn headlines only, not the whole column.  

     

    Column-Headline.PNG

  • Prudence K
    Prudence K ✭✭✭✭

    Stefan - from my previous posting:

    Results tab/View Layout: Hidden here hides from Excel
    Criteria tab/Column Properties/Column Format tab: Hidden here hides from CSV AND from the Results tab View

    So yes, the screenshot you have included is the second option and hiding it there hides it from the CSV AND the Results tab view.  

    However I would recommend you follow a best practice of where to hide fields.  I always hide from the Criteria tab/Column Properties/Column Format tab if I don't want the field in the report because inevitably it turns into a CSV output.  Also, if I know that I always do it there, then I don't have to remember to check both places :)

  • No that really hides the column from all views and from the export :)

  • RichardChan
    RichardChan ✭✭✭✭

    Hi,

    I tried replying to this earlier but looks like it didn't go through

    Excel, PDF etc exports use the view to export the data

    CSV export uses the criteria to export the data

    So hiding , excluding columns in a view will work for Excel, PDF exports but will not affect csv exports, you will need to restrict the number of columns in your criteria

     

     

    Richard

    Neodata Australia

     

     

  • Stefan,

    Is this done for you or are there still questions open?

  • Thanks to all the inputs here my question is solved. Thank you very much to each and every contributor.