Oracle Business Intelligence

Products Banner

Oracle BI Administration Tool: Replace Wizard Not Working

Received Response

I am trying to re-direct my BMM and Presentation layer from Oracle Database 19c to my ADW. Please note that the data in ADW and 19c are identical. I am trying to migrate. When I go to use the "replace wizard" tool, I get this error.

Physical Table "//localhost:1521/orclpdb".."XXX"."FACTTABLE" cannot be replaced with Physical Table "Logistics-ADW".."XXX"."FACTTABLE" in following logical table source(s):
"Logistics Dataset"."Fact Table"."FACTTABLE"
The reason is that replacing table is not joined to any other table(s) in these logical table sources.

I think it maybe has something to do with my alias tables in the BMM but I am not sure, to be honest. Any help would be appreciated.

Please let me know if more information is needed to answer this question



  • If the data is the same, why don't you just change your connection pool in the physical layer to point to your ADW instead?

    If tables have to be renamed, you rename them once (only the "real" physical tables needs to be renamed, aliases will point there). The same for schemas: one rename and job done, any business model built on top will not even know it is using a new database, it will just connect somewhere else.

    The replace tool is more when you have a new table in the same schema that is taking over the role of another table, so it has all the links to other physical objects (dims, facts etc.).

    In your case by trying to replace the source of one logical table with one from a totally different physical database, you probably didn't create any link (physical joins) across the 2 physical databases, and there is where the error come from.

  • I tried this, and it did not work sadly

  • Well, it probably depends a lot on what and how you are doing exactly.

    Maybe take a step (or a few) back to get a global view of what you did, what you would like to do and how you could get there. The RPD does work well for more than 10 years, but it's quite "unique" when starting with it...

    PS: you should also go over the doc about how to setup your employee profile correctly, Oracle employees should have a "-Oracle" (or something like that) added to their profile name.

  • I got it to work finally! The connection pool switching worked. And I have tried to change my name and the system keeps glitching. I will try again.