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OAS 2025:"Log Could Not Be Retrieved" Error When Clicking View Log in Administration>Manage Sessions

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In OAS 2025, attempting to view the detailed session log in the UI Console (Sessions and Query Logs) by clicking the "View Log" link for a specific session results in the following errors:

Error Messages:

Log Could Not Be Retrieved

Error during query processing (SQLExecDirectW)

Error Details:

Error Codes: OPR4ONWY:U9IM8TAC:U9IM8TAC:U9IM8TAC

State: HY000. Code: 10058. [NQODBC] [SQL_STATE: HY000] [nQSError: 10058] A general error has occurred.

State: HY000. Code: 43275. [nQSError: 43275] Message returned from OBIS [ecid:xxxxxxx].

State: HY000. Code: 43261. [nQSError: 43261] Log Viewer process failed to convert obis1-query.json to obis1-query.log: jq is not installed. Please install jq before running this script.

Cause:

This issue is an internal product defect. In OAS 2025, BI Server logs are generated only in JSON format (obis1-query.json, obis1-diagnostic.json), while the standard log format is missing.

A review of the logconfig.xml file (located at <<Domain Home>>/config/fmwconfig/biconfig/OBIS/) reveals the following:

  • Element: /server/ServerInstance/Log/FormatOAS 2025: Set to JSON
  • Element: /server/ServerInstance/UserLog/FormatOAS 2025: Set to JSON

Solution:

To resolve this issue:

  1. Update the logconfig.xml file in the OAS 2025 environment by setting Format = ODL-TEXT,JSON.
  2. Restart the OAS 2025 environment.

After this update, both log formats will be generated in <<Domain Home>>/servers/obis1/logs/, and the "View Log" functionality in the UI Console (Sessions and Query Logs) should work correctly without errors.

Comments

  • Gianni Ceresa
    edited Mar 20, 2025 10:10AM

    Or, as an alternative "solution", just install jq(despite not being listed as a requirement in the doc).

    After installing jq, without any restart, the logs can be viewed in Adminstration > Manage Sessions. At least on linux systems jqis usually available as a package for all distributions.

    Mostly if full-text logs aren't needed explicitly, having only the json version of logs on disk isn't an issue, less space usage.

  • BrandonH
    BrandonH Rank 5 - Community Champion

    On an edge problem in DV on oas 8.2, I tested installing jq instead of adding the text log config, it changed the error from:

    [nQSError: 43261] "Failed to convert the obis1-query.json to obis1-query.log: jq is not installed. Please install jq first before run this script"

    to:

    [nQSError: 46073] Operation 'open()' on file '' failed with error: (2) No such file or directory.

    So in 8.2 / 2025 there are some cases where installing jq might not resolve the problems.

  • To Gianni's point:

    Similar to:
    DV Authentication Required Error Upon Clicking Refresh Button On Developer Pane In Workbook In SSO Configured OAS 2025 (Doc ID 3106981.1)

    Solution: Install jq package.

    Documentation enhancement filed to make sure there is not a missed prerequisite.

    @BrandonH - Thanks for the heads up.