CUPS Fails to Print and Reports “Unable to get printer status”
Applies to:
Oracle Cloud Infrastructure
Symptoms:
After configuring a new printer in CUPS, the “lpstat
” command shows “Connected to printer
” but, after trying to print, nothing is printed and the status changes to “Unable to get printer status
”.
Cause:
The printer configuration is not correct as CUPS was configured to use the “http://<destination_address>:9100/ipp
” URI.
The above-referred URI is incorrect as port 9100 is used by the AppSocket Protocol (aka JetDirect Protocol) which is incompatible with the Internet Printing Protocol (IPP).
Solution:
Review and correct the provided configuration are correct.
Do note that engaging the printer’s vendor may be required as special options may be required on the URI.
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