Oracle Analytics Cloud and Server

Products Banner

Create section breaks in RTF templates

Received Response
664
Views
9
Comments

Summary

Create section breaks in RTF templates

Content

Hello,

I'm having a hard time with an RTF template which sees its tables potentially split when I run the report in Oracle. I have played with the pagination the options bellow :

Split.png

Unfortunately it works when I put in on one table (the 'keep lines options seems to be doing that) but when I put use these pagination rules on several tables it seems to cancel the pagination rules I applied to the tables (like there is a dependency).

So I tried another option which was to insert a continuous break before and after the tables but when I launch the report I ave an error :

Report error.png

So which option could work and how ? Thanks in adavance.


Antoine

Answers

  • please clear you requirement , You can leverage bi publisher section break in RTF template , Thanks

  • Blank page is due extra spaces in the table or at end of loop. please remove all extra white spaces and other , Thanks

  • Hi,

    I encountered the same situation and used the solution you are suggesting. The only issue is, as you mentioned, if on the first page "the child tables are bigger than a single page" the report would render on the second page and leave the first one blank.

    Do you have any solution to avoid the blank page? the tables do render on 2 pages afterwards when the child table is too big so the blank page is useless.

    thanks

    Youssef

  • timdexter
    timdexter ✭✭✭✭✭

    The keep lines together will not affect the tables and they will split.

    When the BIP renderer runs it will work out how much room there is on the page for the data rows to be dispayed. IF there is not enough room, it will break across a page.

    The simplest way to force the renderer to move tables together to the next page rather than split them is to use a single celled parent table.

    1. Cut you existing tables that you would like to keep together

    2. Create a single celled table, place the cursor inside and create a little room with the <CR> key.

    3. Turn off the borders

    4. Highlight the cell and right click it and get to the Table Properties > Row and check the box to ensure the row can not be split

    3. Paste in your tables

    Now when the render runs and see that there is not enough space. It will be forced to move all the tables to the next page because of the parent table's no split setting. At some point, it might not have enough room and will be forced to split ie the child tables are bigger than a single page.

    Hope this helps

    Tim

  • Antoine KAIBER
    Antoine KAIBER ✭✭✭✭✭

    I'm not sure I really understand what you mean but anyway this won't work because the CR key isn't supported (i've tried) so I need to find another solution.

  • timdexter
    timdexter ✭✭✭✭✭

    How do you want the report to behave? I would push back against the business and ask them how they want things to behave.

    If you want the tables kept together and they are collectively too big (rowwise) to fit on the first page, then they will get moved to the second and so on. The renderer can not squeeze the tables down on its own. You need to decide how you want things to behave.

    I did write a blog post a while back about changing the font size to get content to fit - https://blogs.oracle.com/xmlpublisher/one-page-only-please  Its programmatic and not great but it works.

    You could compromise and at least make sure that you repeat the header row(s) of the orphaned table

    Tim

  • Antoine KAIBER
    Antoine KAIBER ✭✭✭✭✭

    Sorry for my late response but i've been quite busy. I've looked at your article but unfortunately I don't think it will help me as I don't want to change the font size.

    Basically I have several tables with variables, and some of them can, in some cases, take up a big part of the page which, if the table starts at 1/2 of the page (for example), can lead to having a split table. What I want is, if that is the case, to push the table onto the next page so it isn't split. For some tables I have headers that repeat themselves but here it's not possible as I do not have any header. Thanks again for your help.

  • timdexter
    timdexter ✭✭✭✭✭

    I see. If you want to keep the table together then you can force to the next page by.

    1. create a 1x1 table.

    2. Click inside it and CR a few times to give yourself some room.

    3. Highlight the table > Properties > Row > Set the do not break across pages radio button

    4. Turn off the table borders

    5. Cut an paste you original table inside the 1x 1 table

    If the inner table is too big for a single page, it will be moved to the next page.

    Tim

  • Antoine KAIBER
    Antoine KAIBER ✭✭✭✭✭

    It seems to be working fine thanks !