Oracle Analytics Cloud and Server

Products Banner

Error when adding display extensions in OAC

Received Response
152
Views
9
Comments

Summary

I have a problem loading the display extensions in my new instance of OAC, I must restart to use them and after a few hours they are no longer available

Content

When adding the extensions downloaded from the following link:
https://www.oracle.com/solutions/business-analytics/data-visualization/extensions.html

It indicates that they were loaded correctly, although refreshing the view and trying to use them do not appear in the extensions section, however if I try to load them again it shows me the following alert:

--The extension with the ID com-company-pointsMapViz already exists. Do you want to overwrite it?

That already exist if I give you overwrite it shows me the following error:

--The connection ID could not be determined. Check that the file you are trying to load contains a valid plugin and try again.

I already tried to restart the OAC instance and the extensions were shown correctly, after a few hours the extensions did not appear again.

I have already used these extensions in previous versions of OAC and ODV.

Version

Oracle Analytics Cloud. 18.3.3-69

error_oac1.png

Answers

  • Hi frank,
    You can try with the last versión of Data Visualization Desktop.
    Maybe in this version work.
    Regards
  • Hi Frank, 

    I've been trying to reproduce this behavior so we can debug the issue but haven't been able to reproduce it.

    Is there a specific click sequence that leads to this ? Or does it happen when you try to upload a plugin after leaving the browser idle for a while? 

    Any pointers will help us in debugging this issue.

    Regards,

    Lalitha

     

  • Hi Lalitha, 
    Thanks for your answer

    I followed the follow steps.

    1. Download a plugin or extentionsfor the follow URL:

    https://www.oracle.com/solutions/business-analytics/data-visualization/extensions.html

    2. In particular i used the follow extentions:

    3. In my OAC service, login as user admin, in the option console then choose "Extensions" in spanish "Extensiones".

    4. Click "Upload Extension" in spanish "Cargar Extensión". I Choose the extention and I clic "OK"

    5. I see the extention and I can use them. But after minutes this extentions disapers.

    6. When I try to upload the same extention , I get the following message, In English “The extension with the ID already exists Do you want to overwrite?

    7. Then I click OK (Si), and I get the follow error:

    I followed the steps describe in this url:

    https://docs.oracle.com/en/cloud/paas/analytics-cloud/acubi/manage-custom-plugins.html

    Thank you very much for your comments.

    Frank Cruz

    steps_oac.png

  • Hi Frank, 

    Thanks for the detailed steps. I have tried to follow the exact same sequence but Iam not able to reproduce the behavior. 

    Not sure what is causing it. I'll keep you posted if we make progress on this issue and find out the cause.

    Regards,

    Lalitha

     

  • Hi all

    I am facing the exactly same error related by Frank. The Oracle Analytics Version is 18.3.3-69 too, and i use OAC STANDARD EDITION and oracle Database 11G R2 Standard Edition.

    I followed the same steps mentioned by Frank to upload and use 2 extensions: customviz-com-company-autoRefresh1.zip e customviz-com-company-rowExpander.zip. I thought find these extensions and delete them, but i can't found them nor in the OAC Linux Server nor in the storage Classic instance (My Services - Containers)

    Tarcisio Vianna

  • Hi Frank, 
     
    I Comment you, that i executed many tests and finded that if i create a OAC service and choose option "Enable IDCS and Load Balancer", 
    then the extensions disappears as you comment previously. 
     
    I tested and verifyed that, if don´t chosse the IDCS the extentions works fine. 
     
    I note same that i create a OAAC service the behaviour is the same, because OAAC use by default the IDCS and load balancer. 
     
    Is important open a SR over this Error.
     
     
    I hope this information can orient your solution...
    Rubi Ruíz.
  • Hi !!

    Very important is your comment, Rubi Ruiz, on creating an analytical instance using IDCS and Load Balancer. In fact, I was having many other problems creating analysis instances in this way, and those issues were resolved when I recreated the instance without checking IDBS and LOAD BALANCER. How ever, I am now using the created OAC without IDCS and LOAD BALANCER, and the  extensions's disappearing errors remains.
    I have another OAC instance created to use ESSBASE, and this one has IDCS and LOAD BALANCER marked. May be this the reason ? 
    But, when the extensions disappear this OAC ESSBASE instance is in stopped state.

  • Hi Tarcisio,

    I dont´n has a OAC instance with ESSBASE, but i think this can cause  the error.
     
    You can delete the extentions that have disappeared. To do this you can restart the instance, in my test, i found extensions appear again, and then you can delete is.
     
    Or your can try is:
     
    1. Log in as an administrative user in OAC, and go to the catalog area. 
     
    2. From there, Switch to the "Admin" view, click "Show Hidden Items", and then navigate to the following path "/System Folders/metadata/bitech.ui.plugins".   
    Existing plugins can be deleted which should restore functionality.   
     
    In any case, can see if OAC ESSBASE instance is in stopped state. 
     
    I hope this can help you.

    Rubi Ruíz.

  • Hi Frank,

    This bug will be fixed in OAC 5.1  (internal version) / 18.4.1 (external version)

    Regards.

    Lenin Valencia