Oracle Business Intelligence

Products Banner

Writeback - buttons not displaying

Received Response
82
Views
12
Comments

We are on OBIEE 11.1.1.7

I believe I properly implemented all the steps, edited all the xml files, made all the property changes (table+ column) and provided all the permissions.

With the Toggle Table Mode checked I don't get the Update button.

With the Toggle Table Mode unchecked, I can type values in the writable fields, but the 3 buttons, Apply/Revert/Done are not displayed.

Appreciate any ideas the community may have.

Thanks,

Steve

Answers

  • Robert Angel
    Robert Angel ✭✭✭✭✭

    Wow, two writebacks in one day.

    First, do yourself a favour and use Apex instead, write back is very limited....

    Second, if you ignore first, have you followed; -

    https://gerardnico.com/dat/obiee/obips/write_back

    Did you bounce the presentation service?

    Are you sure the fields match to the insert / update statements?

  • 3614817
    3614817 ✭✭✭

    Thanks for the quick response!

    First - I will look into Apex

    Second, yes followed these instructions

    Yes bounced the service.

    Double checked the fields match the insert/update statement and it looks to be OK.

  • Robert Angel
    Robert Angel ✭✭✭✭✭

    And the name for the template is letter and case perfect (Linux back end?) and the 'OBIEE' user has sufficient rights to it on the server?

  • 3614817
    3614817 ✭✭✭

    Yes, it is Linux back end.  I will need to check with the DBA to see if the OBIEE user has sufficient rights to the XML template. 

    As for the for the name, I understood it needs to be the name of the WebMessage, not the file name, correct? I did a copy and paste, so is letter/case perfect.

  • Robert Angel
    Robert Angel ✭✭✭✭✭

    On the latter, like this; -

    pastedImage_0.png

    And by OBIEE user I mean the user your OBIEE services run as...

  • 3614817
    3614817 ✭✭✭

    Yes, the name is the same and the OBIEE user as access to the XML file

  • Robert Angel
    Robert Angel ✭✭✭✭✭

    On your last point with the table, are you broadly following; -

    Edit Table Properties view -> writeback & check 'Enable Write Back' & mention Template Name as mentioned in writeback file ( WebMessage name="WriteBack_Template_Name" ).

    Also, from memory I found just leaving a space if I did not want either insert or update did not work for me, I wound up putting a fully formed piece of syntax (having insert in both in my case)

    Also, you have enabled write back in instanceconfig.xml file => <LightWriteback>true</LightWriteback>

    Also, in the rpd you have; -

    Physical Layer - From Physical Table Properties Go to-> General tab dialog box. Uncheck Cacheable

    Business Model & Mapping LayerLogical Column Properties Go to-> General tab. Check Writable option.

    Presentation Layer - Presentation Column Properties Go to-> General tab -> Permissions -> Set permission -> Read / Write (Radio Button), on the User / Application Role which you want to authenticate for WriteBack feature.

    Presentation Layer - Go to -> Manage-> Identity Manager -> Identity Management (Left pane) -> Select Application Role (to which you need Write Back Permission) -> Permission -> Query Limits (tab) -> Select Database (to which you need direct database execution rights) -> Change option from ignore to allow to the field named "Execute Direct Database Requests".

    Finally, you are trying with a sysadmin user or similar with write back rights?

  • Robert Angel
    Robert Angel ✭✭✭✭✭

    For your version you might also want to check

    Other than that I cannot find any applicable patches to your version so it really is just a case of double check every step of the config and if all else fails put together a test case, capture the logs and upload to a SR.

  • 3614817
    3614817 ✭✭✭

    OK, still having problems, but I have solved this specific problem that the buttons were not showing.  It was a permission issue.  "Write Back to Database" was set for "Authenticated User", but as Denied

    Writeback problem - no buttons.jpg

  • Weird enough, You have to enter the name manually like I showed in the screenshot. After that you will see the buttons.

    Mine is OBIEE 12.2.1.3.0 version.

    2018-04-04_9-49-05.png