Oracle Business Intelligence

Products Banner

Privileges for datamodel command-line scripts

Received Response
121
Views
17
Comments

Hi all,

   please does anybody know where to set up privileges for using commands downloadrpd, uploadrpd and all of those? It looks it works natively for weblogic but my account is set up in EM the same way and I can't run the commands under my account. Any idea where is this hidden?

Many thanks

Petr

Tagged:

Answers

  • Joel
    Joel ✭✭✭✭✭

    Can you elaborate? These commands that you have mentioned are executed from the command line and they should be run by a BI Administrator user. Is your user setup as a BI Administrator?

  • Set up privileges for what exactly? Objects in the RPD? What are you trying to do precisely?

  • Boček Petr wrote:my account is set up in EM the same way and I can't run the commands 

    How?

    Where the account come from? (EM isn't a LDAP)

    What privileges / policies does your account have?

  • thanks all for reacting. I'm running for example this command:

    datamodel.cmd downloadrpd -O {path} -SI ssi -U {user} -P {User pass} -W {rpd pass} -S {server} -N 9502

    If I run it under weblogic it is wroking. Running under my account is failing to

    Connection failed, the server processes may be down, the host name, port number, service instance, or protocol (http/https) may be incorrect. Please check server logs, such as bi-lcm-rest.log.0 and obis1-diagnostic.log..

    My account is imported by LDAP and set as administrator the same way like weblogic is. So in EM a canůt any diferences between my account and weblogic account.

  • Boček Petr wrote:My account is imported by LDAP and set as administrator the same way like weblogic is. 

    First question: Are you really sure about that? Is it really a full admin?

  • Tricky question Christian :-) I think I'm sure, but OBI still ensures me I can't be ever sure :-)

    So my contra question would be how or where to check it? Something says me that to be a part of BI administrator role (where weblogic is) is not enough is it?

  • I know X-D

    The point is I managed to do this with accounts other than weblogic and it worked. So I'd say do the following:

    1.) Create 2 new test logins in the WLS security realm and call them "justEMadmin" and "fullWLSadmin"

    2.) "justEMadmin" - give him admin rights in enterprise manager by assigning him to BIAdministrator application role

    3.) "fullWlsadmin" - give him admin rights by making him a member of the WLS administrator group which is then also a memeber pf the BIAdministrator application role.

    see how that works for you

  • By the way the initial question remains: What are you trying to do?

  • I created a specific system of MUD. Where I created scripts to downlad rpd, do some work (offline), create patch, patch rpd and upload online to dev and test environment. It works perfect for almost two months now but the scripts are using weblogic account. This scares me a bit. So I would like to change this to download and upload rpd on users accounts.

  • Hm it looks it still doesn't work. I created those two new users and fullWLSadmin I added to the group Administrators in console. Second one justEMadmin I added only in EM to BIAdminstrators. None of those can run the command above. The error message changed (Connection failed: 401: Unauthorized) but I think the reason is that this is local account.

    Or am I doing something wrong?

  • None can? Ok that's pretty much impossible. Is the user "weblogic" residing in the WLS-embedded LDAP? Or did you push it outside of OBI into the corporate LDAP?

  • Yes none of those can. Yes weblogic has DefaultAuthenticator as provider so is embedded. I'm not able somehow duplicate weblogic account...

  • elb666
    elb666 ✭✭

    Users need to be members of "BIAdministrator" or "BIServiceAdministrator" depending on your environment.  However, when you add a user to a group, there is a lag between adding them and when they actually pick up the group and whatever permissions it is meant to grant them.  It makes testing extremely frustrating!

    Before you test running uploadrpd.sh with the user, log into OBI as the user and make sure you can see BIAdministrator (or BIServiceAdministrator) under "My Account" > "Application Roles".

  • @Boček Petr Sorry lost track of this thread.

    So you need to change the assignment of roles to users? Like in EM? Or do you still need sth that touches the RPD?

  • thanks Elb, these things I know and I have to admit the propagation time is awfull when you are testing something. But still it is not working even the users are part of "BIAdministrator" or "BIServiceAdministrator". Me is a good example. I'm the administrator and neither me can use the commands. So I'm forced to use weblogic account.

  • something strange is happening now... It looks my account is now able to run the commands :-S I need to investigate further and once I have the correct answer I will mark it. Thanks all for now.