Oracle Business Intelligence

Products Banner

OBIEE 12c 12.2.1.1.0 - Sample Application v607 unzip error

Received Response
173
Views
23
Comments

Hi, I'm currently having problems while unzipping the SampleAppv607p-appliance.zip.001. I have tried on two windows machines and even with the previous version (OBIEE 11.1.1.9.0 - Sample Application (V506)), but every time I faced the same errors:

I used the checksum and there seems to be nothing wrong with the installation. I've also tried to modify the filename to SampleAppv607p-appliance.zip.001 as presented in a previous solution

https://community.oracle.com/tech/apps-infra/discussion/4005861/downloading-obiee-virtual-ready-machine-fails

but still the same problem occurs.

I hope some of you can help because I'm stucked

Answers

  • Your files have the wrong names, rename them to have the currect file names and problem will be solved.

    Is your Windows showing you the file extension of files? Because you maybe believe you did rename files to be <something>.zip.001 , .002, .003 etc. While in reality they are still .001.zip etc.

    By default Windows DO NOT show files extensions for known file types, you have the impression to see the real filename, while you only see part of it.

  • Thank you for the answer, you were right and windows was hiding the real file extension

    Now I tried to run the .ova file on the virtual machine but I have a new error:


    This is the very same error code I had before when I was running the wrongly zipped file. I'm currently using the 6.1 version of the virtual box with the predefined configuration, allocating 6,5 Gb of RAM

  • Can't you find some extra logs somewhere? (a log file or whatever)

    That error seem to be quite generic.

    How big is your OVA file? (just checking if all the parts were extracted fully)

  • This is my file properties, now I'm running again the image to check if some more specific problems pop up. It stops around 20% (before your help stopped around 9%)

    Edit: now it stopped at 83% setting 8 Gb RAM and setting the flag to generate new MAC adresses

    Not specific error message unfortunately

  • The file size is correct, so in theory the file is fine.

    I just run an import on Virtualbox 6.1 to see if things work differently today than years ago when it has been released...

  • SHA1 hash of SampleAppv607p-appliance.ova: 2c9ec1d27cd0a5352668c8dda4fd91221c6b2b2f

    MD5 hash of SampleAppv607p-appliance.ova: db035344497c3c8360948ee4b54e8297


    My OVA has the same size as yours, so check the checksum to see if it's the same and that would confirm the OVA is fine.

    It imported fine in my VirtualBox 6.1 in some minutes.


    You should consider googling your virtualbox error and see if you find something. As the file should be fine, the error doesn't sounds like being connected to the content of the OVA but could be related to your VirtualBox setup or host.

  • Sorry, did you keep the default configurations?

  • I did a "next next next" kind of import, didn't change anything and only clicked through the screen accepting what I had to accept.

  • Many thanks for the help, last problem it was me I didn't have enought space to install the vm.

    Now I have another error inside the vm environment while starting the BI:


    NMProcess: WARNING: Bootstrap services are used by OPSS internally and

    clients should never need to directly read/write bootstrap

    credentials. If required, use Wlst or configuration management

    interfaces.

    Node manager started, but cannot connect due to: Error occurred while

    performing nmConnect : Cannot connect to Node Manager. : General

    SSLEngine problem

    Use dumpStack() to view the full stacktrace :

    Unable to connect to NodeManager on host: demo.us.oracle.com, due to

    Error occurred while performing nmConnect : Cannot connect to Node

    Manager. : General SSLEngine problem

    Use dumpStack() to view the full stacktrace :


    Failed to start one or more Servers

  • The VM is very old (too old), all the internal SSL certificates are expired by now.

    You need to turn off time synchronization and change the VM date back in the past. There is another thread in here covering exactly that, let me see if I can find it.

  • https://community.oracle.com/tech/apps-infra/discussion/comment/16823646

    It has the required command (VBoxManage) you need to be able to fully switch off time sync, set the VM to a date in 2017 or 2018 (the VM has been released in 2016).

  • I found on a previous post this command to be used:

    VBoxManage setextradata "SampleAppv607p-appliance" "VBoxInternal/Devices/VMMDev/0/Config/GetHostTimeDisabled" 1

    I tried to launch it from the folder where the vm is installed and the one where the virtual image is stored but none of them worked


    Another issue, probably no connected to this one, I cannot reach these links that I found in the Vm, even disabling proxies


  • VBoxManage is a command coming with VirtualBox, go in the folder where VirtualBox is installed to find it (it's probably not into your path and therefore not visible without a full path). Also, because you are on Windows it's probably going to be VBoxManage.exe

    All the links inside the VM only works if the VM knows how to resolve demo.us.oracle.com to localhost, inside the VM just replace the domain by localhost and they will anyway work. From outside the VM you have to use the IP of the VM (assuming networking configured correctly and not firewall interfering) instead of the domain.

    While the VM will now work, are you sure you need it? It's a 6+ years old thing, so you maybe shouldn't be using it...

  • My supervisor gave me this source to become familiar with obiee. If you have any advice I'll glady take it

  • Well, to become familiar with OBIEE the VM only works for half the work, and it would be the same half as the public demo instance that exist (it was linked somewhere on the official site, can't remember where).

    The VM, just like the demo OAC instance, will let you get familiar with the front end.

    For the backend, the RPD with the models, you will need to install the Admintool first (it only works on Windows, therefore it isn't installed in the VM) and setup a connection to the VM or download a copy of the RPD etc.

    And still: looking at the backend of OBIEE without a proper training to follow is quite useless because you will only guess what is is what and why (and the SampleApp, because of the need was to showcase a lot of things in a single place is by far not an easy RPD to understand).

  • The Docker image will work on any x86-64 OS with Docker. Both Windows, Linux and some Mac (on the new M1 macs no idea if Docker works and if it can run x86_64 images).

    It will give you a fully functional OAS (OBIEE 12c also available in another folder), but empty, no content out of the box, just a clean install.

    Here again it all depends on what your manager mean with "becoming familiar with OBIEE".

    PS: nothing personal or mean, but don't expect to know how OBIEE work by looking around only. You could manage to get the basics of the frontend, but little chances for the RPD and the specialties making OBIEE different from other tools out there.

  • The goal is to bacame familiar with the frontend, not with the dashboards, but with the connection to the databases and the 3 layers. That's what I know so far. I have never installed a docker before...are there some tutorials somewhere? I don't know where to start

  • Thank you both for the support :)

    As in the previous answer to the collegue, I don't aim to get familiar with dashboards but the level beneath (still frontend)

  • So, the 3 layers you should be talking about the RPD: Physical layer, Business Model and Mapping layer and Presentation layer. That is the backend, the RPD is like all the knowledge that you feed into the brain to make decisions based on the requests sent from the frontend.

    The RPD of SampleApp is very large and fairly complicated with various horizontal federations to showcase the various sources.

    That is the part that you have little chances to understand just by looking to it. There are some concepts which are unique to OBIEE and you will not find anywhere else.

  • Yes, I meant those three layers. Fortunately I'm not alone because I have a supervisor with experience in OBIEE, my problem is that I am a newbie in my company and I don't have access to real data. My supervisor suggested me to work with the samples in the virtual machine to get some experience first