NetSuite MyLearn: Boost your productivity and maximize your use of NetSuite with Training and Certifications delivered by Education Services expert resources.


Check out Oracle NetSuite upcoming events and conferences here
Now is the time to ask your NetSuite-savvy friends and colleagues to join the NetSuite Support Community! Refer now! Click here to watch and learn more!
Attention: Customers with NetSuite Electronic Bank Payment (EBP) SuiteApp, version 2020.2 QA (ID 315896) must UPDATE (do NOT uninstall) their bundle to the Production version 2022.1 (ID 416781) by December 31, 2022. Note: If users fail to manually update the Electronic Bank Payments SuiteApp within the given time window, this version of the SuiteApp (ID: 315896) will be deprecated and the account will not be updated to Leading version (2022.1) of the Electronic Bank Payments SuiteApp. Please refer to the campaign email sent to impacted customers for more information.
Update your Profile with your Support type to get your Support Type badge.
NetSuite Release 2023.1 is here! Download the release notes and post your questions in the new Release 2023.1 category.
Join the webinar and "Get the Most Out of NetSuite Inventory Management" on May 2, 2023 at 10 AM PST. Click on this link to register. Do not forget to RSVP on this page as well!
Something new and exciting is coming in the Community on April 5, 2023. Follow Community Whiz category so you won't miss out!

Map Reduce fails while processing search results

edited May 20, 2020 11:28AM in SuiteCloud / Customization 3 comments


I have a custom function that I call from a Map reduce script. This function loads a search at runtime and processes its results. The search id is passed as a parameter to map reduce.

For a specific search, Map/Reduce errors out and completes prematurely, specifically at .runPaged, ( or .each or at .getRange(), tried all 3).

Just to make sure, I ran the same function with same parameters in a scheduled script, and the scheduled script processes it just fine.

I run the Map Reduce with a different parameter (different search id), and it processes just fine, which makes me think that slow running complex searches aren't handled gracefully within the Map Reduce script context.


Howdy, Stranger!

Log In

To view full details, sign in.


Don't have an account? Click here to get started!


This Week's Leaders

This Month's Leaders

All Time Leaders