You're almost there! Please answer a few more questions for access to the Applications content. Complete registration
Interested in joining? Complete your registration by providing Areas of Interest here. Register

Download a file using migration API v1 results in HTTP 416 error

Accepted answer
35
Views
10
Comments
edited May 5, 2020 8:39PM in Planning 10 comments

Summary

EPM Cloud documentation indicates the API version to use for "Download File" is v1, not 11.1.2.3.600. Attempting to "GET" the "download Link" results in 416 error

Content

Our existing code was using the current API version for 'Migration' - 11.1.2.3.600. However, the online documentation indicates that the version to be used is v1 - https://docs.oracle.com/en/cloud/saas/enterprise-performance-management-common/prest/download.html

So, we tried switching over to the new API version.

Tested it using the 'RESTED' API client in Firefox, as well as in a Groovy program with the same result. The initial call - <instance-url>/interop/rest/v1/applicationsnapshots/<file-name>/contents

Howdy, Stranger!

Log In

To view full details, sign in.

Register

Don't have an account? Click here to get started!