We'd love to hear from you! Provide  feedback  to earn a badge today. Take our quick survey
You're almost there! Please answer a few more questions for access to the Applications content. Complete registration
Interested in joining? Complete your registration by providing Areas of Interest here. Register

Can not receive UDP packet on Oracle Cloud Compute instance.

Accepted answer
12
Views
3
Comments
edited Jul 15, 2021 4:10AM in Oracle Cloud Infrastructure - General 3 comments

Summary

I send a UDP packet to Oracle Cloud Compute instance. It doesn't get there.

Content

On Oracle Cloud Compute instance, I run "netcat -u -l -p 20000".

On my home computer I run "echo hello|netcat -u 150.230.43.58 20000".  Packet never gets to my Oracle Cloud Compute instance.  150.230.43.58 is my Oracle Cloud Compute instance public IP address.  "ping 150.230.43.58" works from home.  "ssh [email protected]" works.

If I run "netcat -u -l -p 20000" on my home computer and run "echo hello|netcat -u myhomecomputer 20000", then packet gets to my home computer.

In my Security List I have a single ingress rule that says "All traffic for all ports" under "allows".

Tagged:

Howdy, Stranger!

Log In

To view full details, sign in.

Register

Don't have an account? Click here to get started!